summaryrefslogtreecommitdiff
path: root/app-admin/tpm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-admin/tpm
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-admin/tpm')
-rw-r--r--app-admin/tpm/Manifest4
-rw-r--r--app-admin/tpm/metadata.xml23
-rw-r--r--app-admin/tpm/tpm-1.3.3.ebuild24
-rw-r--r--app-admin/tpm/tpm-9999.ebuild24
4 files changed, 75 insertions, 0 deletions
diff --git a/app-admin/tpm/Manifest b/app-admin/tpm/Manifest
new file mode 100644
index 000000000000..d1406ae26fef
--- /dev/null
+++ b/app-admin/tpm/Manifest
@@ -0,0 +1,4 @@
+DIST tpm-1.3.3.tar.gz 14623 BLAKE2B efff44b542cc5731c5e2b4527721161e3ad73088eb8ac5f46012dd7da823d67045994f64d830eef48a136fbc4fbb8df04235a10fc9d0e867a8ea2b3a01d1b01e SHA512 113ba21300d2a5fdfb1c058c3f496b004195b68576a832c5ad89b8baecd2d18660ba108e2e7a5ae68148dd60bdaacaee5f5024905b8fc07184a577e0837ae204
+EBUILD tpm-1.3.3.ebuild 555 BLAKE2B 19d3e1bebc06bc72a5a6a401262c2dfe4a734c9465466ca0fcc039b36068279340df80f9959c299889a409a9761ae9d58d0b3e30f1df61142b4d6f53938f210c SHA512 c2fd4eb235cdf8507b0dc82e8e9b79af0f6f2e5e3ec669b26fd26a1aec28e6e4fba89f3a785cbe668de39f1eba470f16c0a8072111b12d94769243f714232789
+EBUILD tpm-9999.ebuild 555 BLAKE2B 19d3e1bebc06bc72a5a6a401262c2dfe4a734c9465466ca0fcc039b36068279340df80f9959c299889a409a9761ae9d58d0b3e30f1df61142b4d6f53938f210c SHA512 c2fd4eb235cdf8507b0dc82e8e9b79af0f6f2e5e3ec669b26fd26a1aec28e6e4fba89f3a785cbe668de39f1eba470f16c0a8072111b12d94769243f714232789
+MISC metadata.xml 793 BLAKE2B be7b53660d81a145da5682bab4f84f3c732f2c735db9cf2c32daa5ae887677500aeaa28ec03997f1417a3d23118003f0087e4e98e1261301686e7e608d99c119 SHA512 65b07e08517e1955a5811fa942efe3c71362deff8b64a15f33968f4e12e8f4f1be9d44a450204a30f8cbefa1fdd5ff368f2fd3d9c6d556644263a2e89a308c80
diff --git a/app-admin/tpm/metadata.xml b/app-admin/tpm/metadata.xml
new file mode 100644
index 000000000000..40605a691828
--- /dev/null
+++ b/app-admin/tpm/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ tpm is a tiny shell script which is heavily inspired and
+ largely compatible with pass(1). Just like pass it uses
+ gpg2(1) to securely store your passwords, the major difference
+ between pass and tpm is that the latter is a lot more minimal.
+ Furthermore, tpm is written entirely in POSIX shell.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">nmeum/tpm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/tpm/tpm-1.3.3.ebuild b/app-admin/tpm/tpm-1.3.3.ebuild
new file mode 100644
index 000000000000..dd2b55edef2e
--- /dev/null
+++ b/app-admin/tpm/tpm-1.3.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tiny password manager"
+HOMEPAGE="https://github.com/nmeum/tpm"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nmeum/${PN}.git"
+else
+ SRC_URI="https://github.com/nmeum/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+BDEPEND="dev-lang/perl"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}
diff --git a/app-admin/tpm/tpm-9999.ebuild b/app-admin/tpm/tpm-9999.ebuild
new file mode 100644
index 000000000000..dd2b55edef2e
--- /dev/null
+++ b/app-admin/tpm/tpm-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tiny password manager"
+HOMEPAGE="https://github.com/nmeum/tpm"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nmeum/${PN}.git"
+else
+ SRC_URI="https://github.com/nmeum/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+BDEPEND="dev-lang/perl"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}