summaryrefslogtreecommitdiff
path: root/app-admin/swatchdog/swatchdog-3.2.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/swatchdog/swatchdog-3.2.4-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/swatchdog/swatchdog-3.2.4-r1.ebuild')
-rw-r--r--app-admin/swatchdog/swatchdog-3.2.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/swatchdog/swatchdog-3.2.4-r1.ebuild b/app-admin/swatchdog/swatchdog-3.2.4-r1.ebuild
new file mode 100644
index 000000000000..c572801b8f3a
--- /dev/null
+++ b/app-admin/swatchdog/swatchdog-3.2.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL_SUBSLOT=yes
+inherit perl-app
+
+DESCRIPTION="Simple log watcher"
+HOMEPAGE="https://sourceforge.net/projects/swatch/"
+SRC_URI="mirror://sourceforge/swatch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-perl/Date-Manip
+ dev-perl/Date-Calc
+ dev-perl/File-Tail
+ dev-perl/TimeDate
+ >=virtual/perl-Time-HiRes-1.12
+ !app-admin/swatch"
+
+src_install() {
+ emake install
+ newinitd "${FILESDIR}/${PN}-init" "${PN}"
+ newconfd "${FILESDIR}/${PN}-confd" "${PN}"
+ insinto /etc
+ doins "${FILESDIR}/${PN}rc"
+
+ # Clean up perl localpod and packlist (bug #620886)
+ perl_delete_localpod
+ perl_fix_packlist
+}