summaryrefslogtreecommitdiff
path: root/app-admin/sud/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/sud/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/sud/files')
-rw-r--r--app-admin/sud/files/sud-1.3-fix-build-system.patch30
-rw-r--r--app-admin/sud/files/sud.rc620
2 files changed, 50 insertions, 0 deletions
diff --git a/app-admin/sud/files/sud-1.3-fix-build-system.patch b/app-admin/sud/files/sud-1.3-fix-build-system.patch
new file mode 100644
index 000000000000..5937d3f0a8e6
--- /dev/null
+++ b/app-admin/sud/files/sud-1.3-fix-build-system.patch
@@ -0,0 +1,30 @@
+--- a/login/Makefile.am
++++ b/login/Makefile.am
+@@ -2,5 +2,5 @@
+ ilogin_SOURCES = login.c
+ ilogin_CFLAGS = -Wall
+
+-install-data-hook:
+- chmod 500 $(sbindir)/ilogin
++install-exec-hook:
++ chmod 500 $(DESTDIR)$(sbindir)/ilogin
+--- a/su/Makefile.am
++++ b/su/Makefile.am
+@@ -4,5 +4,5 @@
+
+ INCLUDES = -I../sud
+
+-install-data-hook:
+- chmod 555 $(bindir)/suz
++install-exec-hook:
++ chmod 555 $(DESTDIR)$(bindir)/suz
+--- a/sud/Makefile.am
++++ b/sud/Makefile.am
+@@ -7,5 +7,5 @@
+ #INCLUDES = -I..
+ CLEANFILES = conf_lexer.c conf_parser.h conf_parser.c
+
+-install-data-hook:
+- chmod 500 $(sbindir)/sud
++install-exec-hook:
++ chmod 500 $(DESTDIR)$(sbindir)/sud
diff --git a/app-admin/sud/files/sud.rc6 b/app-admin/sud/files/sud.rc6
new file mode 100644
index 000000000000..068acf776173
--- /dev/null
+++ b/app-admin/sud/files/sud.rc6
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting sud"
+ start-stop-daemon --start --quiet --pidfile /var/run/sud.pid \
+ --exec /usr/sbin/sud
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping sud"
+ start-stop-daemon --stop --quiet --pidfile /var/run/sud.pid
+ eend $?
+}