summaryrefslogtreecommitdiff
path: root/app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
commit0ded23e9afc3d3424aef90e5cec3f2ca6d6b4c30 (patch)
tree93ef9828fae35063d273f386b2fa4a7130add56b /app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild
parent22b4e2ee9c8011b75d7c030d6129a7487494aeba (diff)
gentoo auto-resync : 13:12:2023 - 11:40:30
Diffstat (limited to 'app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild')
-rw-r--r--app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild b/app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..13583265e579
--- /dev/null
+++ b/app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+SMU_PN="ryzen_smu"
+SMU_PV="0.1.5"
+inherit toolchain-funcs
+
+DESCRIPTION="Monitor power information of Ryzen processors via the PM table of the SMU"
+HOMEPAGE="https://github.com/hattedsquirrel/ryzen_monitor"
+SRC_URI="
+ https://github.com/hattedsquirrel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://gitlab.com/leogx9r/${SMU_PN}/-/archive/v${SMU_PV}/${SMU_PN}-v${SMU_PV}.tar.bz2
+"
+
+LICENSE="AGPL-3 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-admin/ryzen_smu"
+
+src_unpack() {
+ unpack "${P}.tar.gz" "${SMU_PN}-v${SMU_PV}.tar.bz2"
+}
+
+src_prepare() {
+ rm "src/lib/"* || die
+ cp -a "${WORKDIR}/${SMU_PN}-v${SMU_PV}/lib/libsmu."{c,h} "src/lib/" || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/ryzen_monitor
+}