summaryrefslogtreecommitdiff
path: root/app-admin/rsyslog/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /app-admin/rsyslog/files
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'app-admin/rsyslog/files')
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.24.0-fix-tcpflood-without-librelp-r1.patch160
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.26.0-fix-zmq3-format-security.patch39
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-hostname-detection-when-getaddrinfo-fails.patch27
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-librdkafka-detection.patch43
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.30.0-fix-kerberos.patch22
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.34.0-fix-issue2612.patch13
6 files changed, 13 insertions, 291 deletions
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.24.0-fix-tcpflood-without-librelp-r1.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.24.0-fix-tcpflood-without-librelp-r1.patch
deleted file mode 100644
index a03a6562722a..000000000000
--- a/app-admin/rsyslog/files/8-stable/rsyslog-8.24.0-fix-tcpflood-without-librelp-r1.patch
+++ /dev/null
@@ -1,160 +0,0 @@
-Patch to allow building of tcpflood without librelp
-
-Cherry pick of
-https://github.com/rsyslog/rsyslog/commit/73e3b7ab2f8a3974d31844b492ad02d61ed5727f
-https://github.com/rsyslog/rsyslog/pull/1493
-
-
-Gentoo-Bug: https://bugs.gentoo.org/613264
-Gentoo-Bug: https://bugs.gentoo.org/614424
-
-diff -u b/tests/tcpflood.c b/tests/tcpflood.c
---- b/tests/tcpflood.c
-+++ b/tests/tcpflood.c
-@@ -96,7 +96,9 @@
- #include <string.h>
- #include <netinet/in.h>
- #include <pthread.h>
-+#ifdef ENABLE_RELP
- #include <librelp.h>
-+#endif
- #include <sys/resource.h>
- #include <sys/time.h>
- #include <errno.h>
-@@ -149,7 +151,9 @@
- static int numConnections = 1; /* number of connections to create */
- static int softLimitConnections = 0; /* soft connection limit, see -c option description */
- static int *sockArray; /* array of sockets to use */
-+#ifdef ENABLE_RELP
- static relpClt_t **relpCltArray; /* array of sockets to use */
-+#endif
- static int msgNum = 0; /* initial message number to start with */
- static int bShowProgress = 1; /* show progress messages */
- static int bSilent = 0; /* completely silent operation */
-@@ -216,6 +220,7 @@
- static int sendTLS(int i, char *buf, int lenBuf);
- static void closeTLSSess(int __attribute__((unused)) i);
-
-+#ifdef ENABLE_RELP
- /* RELP subsystem */
- #pragma GCC diagnostic push
- #pragma GCC diagnostic ignored "-Wformat-security"
-@@ -235,6 +240,7 @@
- CHKRELP(relpEngineSetEnableCmd(pRelpEngine, (unsigned char*)"syslog",
- eRelpCmdState_Required));
- }
-+#endif /* #ifdef ENABLE_RELP */
-
- /* prepare send subsystem for UDP send */
- static int
-@@ -273,6 +279,7 @@
- port = targetPort;
- }
- if(transport == TP_RELP_PLAIN) {
-+ #ifdef ENABLE_RELP
- relpRetVal relp_r;
- relpClt_t *relpClt;
- char relpPort[16];
-@@ -286,6 +293,7 @@
- return(1);
- }
- *fd = 1; /* mimic "all ok" state */
-+ #endif
- } else { /* TCP, with or without TLS */
- if((sock=socket(AF_INET, SOCK_STREAM, 0))==-1) {
- perror("\nsocket()");
-@@ -336,8 +344,10 @@
- sessArray = calloc(numConnections, sizeof(gnutls_session_t));
- # endif
- sockArray = calloc(numConnections, sizeof(int));
-+ #ifdef ENABLE_RELP
- if(transport == TP_RELP_PLAIN)
- relpCltArray = calloc(numConnections, sizeof(relpClt_t*));
-+ #endif
- for(i = 0 ; i < numConnections ; ++i) {
- if(i % 10 == 0) {
- if(bShowProgress)
-@@ -356,8 +366,10 @@
- * at least something.
- */
- if(transport == TP_RELP_PLAIN) {
-+ #ifdef ENABLE_RELP
- CHKRELP(relpEngineCltDestruct(pRelpEngine,
- relpCltArray+i));
-+ #endif
- } else { /* TCP and TLS modes */
- if(transport == TP_TLS)
- closeTLSSess(i);
-@@ -403,14 +415,13 @@
-
- if(bShowProgress)
- if(write(1, " close connections", sizeof(" close connections")-1)){}
-- //if(transport == TP_RELP_PLAIN)
-- //sleep(10); /* we need to let librelp settle a bit */
- for(i = 0 ; i < numConnections ; ++i) {
- if(i % 10 == 0 && bShowProgress) {
- lenMsg = sprintf(msgBuf, "\r%5.5d", i);
- if(write(1, msgBuf, lenMsg)){}
- }
- if(transport == TP_RELP_PLAIN) {
-+ #ifdef ENABLE_RELP
- relpRetVal relpr;
- if(sockArray[i] != -1) {
- relpr = relpEngineCltDestruct(pRelpEngine, relpCltArray+i);
-@@ -419,6 +430,7 @@
- }
- sockArray[i] = -1;
- }
-+ #endif
- } else { /* TCP and TLS modes */
- if(sockArray[i] != -1) {
- /* we try to not overrun the receiver by trying to flush buffers
-@@ -610,6 +622,7 @@
- offsSendBuf = lenBuf;
- }
- } else if(transport == TP_RELP_PLAIN) {
-+ #ifdef ENABLE_RELP
- relpRetVal relp_ret;
- if(sockArray[socknum] == -1) {
- /* connection was dropped, need to re-establish */
-@@ -627,6 +640,7 @@
- printf("\nrelpCltSendSyslog() failed with relp error code %d\n",
- relp_ret);
- }
-+ #endif
- }
- if(lenSend != lenBuf) {
- printf("\r%5.5d\n", i);
-@@ -1106,7 +1120,9 @@
- transport = TP_RELP_PLAIN;
- # else
- fprintf(stderr, "compiled without RELP support: "
-- "\"-Trelp-plain\" not supported!\n");
-+ "\"-Trelp-plain\" not supported!\n"
-+ "(add --enable-relp to ./configure options "
-+ "if desired)\n");
- exit(1);
- # endif
- } else {
-@@ -1168,7 +1184,9 @@
- if(transport == TP_TLS) {
- initTLS();
- } else if(transport == TP_RELP_PLAIN) {
-+ #ifdef ENABLE_RELP
- initRELP_PLAIN();
-+ #endif
- }
-
- if(openConnections() != 0) {
-@@ -1183,9 +1201,11 @@
-
- closeConnections(); /* this is important so that we do not finish too early! */
-
-+ #ifdef ENABLE_RELP
- if(transport == TP_RELP_PLAIN) {
- CHKRELP(relpEngineDestruct(&pRelpEngine));
- }
-+ #endif
-
- if(nConnDrops > 0 && !bSilent)
- printf("-D option initiated %ld connection closures\n", nConnDrops);
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.26.0-fix-zmq3-format-security.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.26.0-fix-zmq3-format-security.patch
deleted file mode 100644
index b285798bfe45..000000000000
--- a/app-admin/rsyslog/files/8-stable/rsyslog-8.26.0-fix-zmq3-format-security.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/contrib/imzmq3/imzmq3.c
-+++ b/contrib/imzmq3/imzmq3.c
-@@ -403,7 +403,7 @@ static rsRetVal createSocket(instanceConf_t* info, void** sock) {
-
- /* Do the bind/connect... */
- if (info->action==ACTION_CONNECT) {
-- rv = zsocket_connect(*sock, info->description);
-+ rv = zsocket_connect(*sock, "%s", info->description);
- if (rv == -1) {
- errmsg.LogError(0,
- RS_RET_INVALID_PARAMS,
-@@ -413,7 +413,7 @@ static rsRetVal createSocket(instanceConf_t* info, void** sock) {
- }
- DBGPRINTF("imzmq3: connect for %s successful\n",info->description);
- } else {
-- rv = zsocket_bind(*sock, info->description);
-+ rv = zsocket_bind(*sock, "%s", info->description);
- if (rv == -1) {
- errmsg.LogError(0,
- RS_RET_INVALID_PARAMS,
---- a/contrib/omzmq3/omzmq3.c
-+++ b/contrib/omzmq3/omzmq3.c
-@@ -242,14 +242,14 @@ static rsRetVal initZMQ(instanceData* pData) {
- if (pData->action == ACTION_BIND) {
- /* bind asserts, so no need to test return val here
- which isn't the greatest api -- oh well */
-- if(-1 == zsocket_bind(pData->socket, (char*)pData->description)) {
-+ if(-1 == zsocket_bind(pData->socket, "%s", (char*)pData->description)) {
- errmsg.LogError(0, RS_RET_NO_ERRCODE, "omzmq3: bind failed for %s: %s",
- pData->description, zmq_strerror(errno));
- ABORT_FINALIZE(RS_RET_NO_ERRCODE);
- }
- DBGPRINTF("omzmq3: bind to %s successful\n",pData->description);
- } else {
-- if(-1 == zsocket_connect(pData->socket, (char*)pData->description)) {
-+ if(-1 == zsocket_connect(pData->socket, "%s", (char*)pData->description)) {
- errmsg.LogError(0, RS_RET_NO_ERRCODE, "omzmq3: connect failed for %s: %s",
- pData->description, zmq_strerror(errno));
- ABORT_FINALIZE(RS_RET_NO_ERRCODE);
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-hostname-detection-when-getaddrinfo-fails.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-hostname-detection-when-getaddrinfo-fails.patch
deleted file mode 100644
index a9470ccf4b60..000000000000
--- a/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-hostname-detection-when-getaddrinfo-fails.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 1a7d3a088969b47798bc1da712ca2772f91a7c02 Mon Sep 17 00:00:00 2001
-From: Jiri Vymazal <jvymazal@redhat.com>
-Date: Wed, 31 May 2017 16:26:56 +0200
-Subject: [PATCH] Ignoring NONAME error from getaddrinfo so we have hostname
- set even without working network
-
----
- runtime/net.c | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/runtime/net.c b/runtime/net.c
-index 2d8de9429..edffc677a 100644
---- a/runtime/net.c
-+++ b/runtime/net.c
-@@ -1188,7 +1188,11 @@ getLocalHostname(uchar **ppName)
- memset(&flags, 0, sizeof(flags));
- flags.ai_flags = AI_CANONNAME;
- int error = getaddrinfo((char*)hnbuf, NULL, &flags, &res);
-- if (error != 0) {
-+ if (error != 0 &&
-+ error != EAI_NONAME && error != EAI_AGAIN && error != EAI_FAIL) {
-+ /* If we get one of errors above, network is probably
-+ * not working yet, so we fall back to local hostname below
-+ */
- dbgprintf("getaddrinfo: %s\n", gai_strerror(error));
- ABORT_FINALIZE(RS_RET_IO_ERROR);
- }
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-librdkafka-detection.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-librdkafka-detection.patch
deleted file mode 100644
index 366c0afaca84..000000000000
--- a/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-librdkafka-detection.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -1695,12 +1695,14 @@ AM_CONDITIONAL(ENABLE_KAFKA_TESTS, test x$enable_kafka_tests = xyes)
-
- # omkafka works with older library
- if test "x$enable_omkafka" = "xyes"; then
-- PKG_CHECK_MODULES([LIBRDKAFKA], [librdkafka],, [
-- AC_CHECK_LIB([rdkafka], [rd_kafka_produce], [
-- AC_MSG_WARN([librdkafka is missing but library present, using -lrdkafka])
-- LIBRDKAFKA_LIBS=-lrdkafka
-- ], [
-- AC_MSG_ERROR([could not find rdkafka library])
-+ PKG_CHECK_MODULES([LIBRDKAFKA], [rdkafka],, [
-+ PKG_CHECK_MODULES([LIBRDKAFKA], [librdkafka],, [
-+ AC_CHECK_LIB([rdkafka], [rd_kafka_produce], [
-+ AC_MSG_WARN([librdkafka is missing but library present, using -lrdkafka])
-+ LIBRDKAFKA_LIBS=-lrdkafka
-+ ], [
-+ AC_MSG_ERROR([could not find rdkafka library])
-+ ])
- ])
- ])
- AC_CHECK_HEADERS([librdkafka/rdkafka.h])
-@@ -1708,12 +1710,13 @@ fi
-
- # imkafka needs newer library
- if test "x$enable_imkafka" = "xyes"; then
-- PKG_CHECK_MODULES(LIBRDKAFKA, rdkafka >= 0.9.1)
-- AC_CHECK_LIB([rdkafka], [rd_kafka_produce], [
-- AC_MSG_WARN([librdkafka is missing but library present, using -lrdkafka])
-- LIBRDKAFKA_LIBS=-lrdkafka
-- ], [
-- AC_MSG_ERROR([could not find rdkafka library])
-+ PKG_CHECK_MODULES([LIBRDKAFKA], [rdkafka >= 0.9.1],, [
-+ AC_CHECK_LIB([rdkafka], [rd_kafka_produce], [
-+ AC_MSG_WARN([librdkafka is missing but library present, using -lrdkafka])
-+ LIBRDKAFKA_LIBS=-lrdkafka
-+ ], [
-+ AC_MSG_ERROR([could not find rdkafka library])
-+ ])
- ])
- AC_CHECK_HEADERS([librdkafka/rdkafka.h])
- fi
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.30.0-fix-kerberos.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.30.0-fix-kerberos.patch
deleted file mode 100644
index a202e633c893..000000000000
--- a/app-admin/rsyslog/files/8-stable/rsyslog-8.30.0-fix-kerberos.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://github.com/rsyslog/rsyslog/issues/1838
-
---- a/plugins/imgssapi/imgssapi.c
-+++ b/plugins/imgssapi/imgssapi.c
-@@ -291,7 +291,7 @@ finalize_it:
-
-
- static rsRetVal
--doRcvData(tcps_sess_t *pSess, char *buf, size_t lenBuf, ssize_t *piLenRcvd)
-+doRcvData(tcps_sess_t *pSess, char *buf, size_t lenBuf, ssize_t *piLenRcvd, int *const oserr)
- {
- DEFiRet;
- int allowedMethods;
-@@ -307,7 +307,7 @@ doRcvData(tcps_sess_t *pSess, char *buf, size_t lenBuf, ssize_t *piLenRcvd)
- CHKiRet(TCPSessGSSRecv(pSess, buf, lenBuf, piLenRcvd));
- } else {
- *piLenRcvd = lenBuf;
-- CHKiRet(netstrm.Rcv(pSess->pStrm, (uchar*) buf, piLenRcvd) != RS_RET_OK);
-+ CHKiRet(netstrm.Rcv(pSess->pStrm, (uchar*) buf, piLenRcvd, oserr));
- }
-
- finalize_it:
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.34.0-fix-issue2612.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.34.0-fix-issue2612.patch
new file mode 100644
index 000000000000..4e9e566e84c7
--- /dev/null
+++ b/app-admin/rsyslog/files/8-stable/rsyslog-8.34.0-fix-issue2612.patch
@@ -0,0 +1,13 @@
+https://github.com/rsyslog/rsyslog/issues/2612
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -254,7 +254,7 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM(, return __builtin_expect(main != 0, 1))],
+ # speeds up processig.
+ # note that when automic operations are enabled but not available, they
+ # will silently NOT be used!
+-AC_ARG_ENABLE(regexp,
++AC_ARG_ENABLE(atomic_operations,
+ [AS_HELP_STRING([--enable-atomic-operations],[Enable atomic operation support @<:@default=yes@:>@])],
+ [case "${enableval}" in
+ yes) enable_atomic_operations="yes" ;;