summaryrefslogtreecommitdiff
path: root/app-admin/qpage/qpage-3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-admin/qpage/qpage-3.3.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-admin/qpage/qpage-3.3.ebuild')
-rw-r--r--app-admin/qpage/qpage-3.3.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-admin/qpage/qpage-3.3.ebuild b/app-admin/qpage/qpage-3.3.ebuild
index 01cddbc87320..9231daae0add 100644
--- a/app-admin/qpage/qpage-3.3.ebuild
+++ b/app-admin/qpage/qpage-3.3.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils toolchain-funcs
+EAPI=6
+
+inherit toolchain-funcs
DESCRIPTION="Sends messages to an alphanumeric pager via TAP protocol"
HOMEPAGE="http://www.qpage.org/"
@@ -16,30 +18,26 @@ DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
RDEPEND="${DEPEND}
virtual/mta"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch "${FILESDIR}"/${P}-fix-warning.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-fix-warning.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
-src_compile() {
+src_configure() {
tc-export CC
- econf || die "econf failed"
+ default
# There doesn't seem to be a clean way to disable tcp wrappers in
# this package if you have it installed, but don't want to use it.
if ! use tcpd ; then
- sed -i 's/-lwrap//g; s/-DTCP_WRAPPERS//g' Makefile
- echo '#undef TCP_WRAPPERS' >> config.h
+ sed -i 's/-lwrap//g; s/-DTCP_WRAPPERS//g' Makefile || die
+ echo '#undef TCP_WRAPPERS' >> config.h || die
fi
-
- emake || die "emake failed"
}
src_install() {
- einstall || die "einstall failed"
+ default
dodir /var/spool/qpage
fowners daemon:daemon /var/spool/qpage
@@ -50,7 +48,7 @@ src_install() {
fperms 770 /var/lock/subsys/qpage
insinto /etc/qpage
- doins example.cf || die "doins example.cf failed"
+ doins example.cf
doinitd "${FILESDIR}"/qpage
}