summaryrefslogtreecommitdiff
path: root/app-admin/puppet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
commitf1bc537f089cc8477a9a18db597cb349e1b00e91 (patch)
treec48eb730c43e5f35729fabbe5cb4bfbe4a1bc794 /app-admin/puppet
parentcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (diff)
gentoo resync : 16.06.2018
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest2
-rw-r--r--app-admin/puppet/puppet-5.5.2.ebuild144
2 files changed, 146 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 4ab191849edb..481d382315f4 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -10,6 +10,8 @@ AUX puppetmaster.init-4.x 1108 BLAKE2B 1793d3d881de2c1808159f940bf1e758c2e7fad8f
AUX tmpfiles.d 39 BLAKE2B 2c9a992bf709a384ae02395299ddeb2febf3cd83b924acd97d0ca7fbc17dac273cb27c926790708c0d929f62282dec0477f167ed2e5fc1418a9ff5d130f246f1 SHA512 2dfec45e6f762ce0431d55b1a826e707e970defacbe050df838b66b347e7423eac78a35248c74908e7b52fa84cde5129ce3f562f64dac357f0368a3bc0b719a1
DIST puppet-4.10.11.tar.gz 3022878 BLAKE2B d3eec840bb1c46e0dfbbc9dad598b362049a76c7ee60b4ff314e7ba2ce19613f834baced94afbbf499b513391107c4229be5f40c275d0724b200358722db0e96 SHA512 5eaac8bd973d0013e7774c9bda81524332f2b3b0177c04e78554bfb0815697b4b296d5dd11a04f7fad782ad975b350b149b1cd97fc5f06974952314f163f1b40
DIST puppet-5.5.1.tar.gz 3035639 BLAKE2B 2930ca9eb928d7c6a69ea76673fc4d002e230bf6dbcd28764e8d5bd504ae11326dc856ed64480e13c9eb1d683ad5e8ef64fc9e217942b59d90c6a0bc98e0197c SHA512 20bf7094193f30cfc7a91244275fc79eef0296036ffbc6bbe405e9ca75123b722be6855c746ef8cd35f80bd7a7308408a9205d064f0f910e11877e4db0ebdabc
+DIST puppet-5.5.2.tar.gz 3036714 BLAKE2B 8be2c2fa7b66a2fd8d413f01afad22f7e0724c31a0a92b777f1b61e2139f14f3284a11cfb52fea8833556208d8bb3e99f20b1ed4fa2816809eaa4b92fa730cd5 SHA512 4995b6b6d1b75d68dd4c8eba37585c0afa88f9c6b78857e837886ea72b373c884182adf8791e0c9f2a5079f22681a40073e512e6b727ecfcaff463c8024cf5db
EBUILD puppet-4.10.11.ebuild 5633 BLAKE2B f75ee3a7cb27288448f341a560e20b3b1246c37a690846bfda63d0ee9ea41600606a986160bb1967ad7c279a4d2204b54af1e45204e43725b4c1438ceb81e7a4 SHA512 90e2636f668b3227ece18ff03a16c28e7791c6ec192a87ca89395a03bc9182abdabb43ac6fc5261da7c4afd68caefaabe81549d39e7fd018cc0b5f307baded2f
EBUILD puppet-5.5.1.ebuild 3833 BLAKE2B 1fe39216139f93fc68ae0965596931a4d1ad1114d78353001a710d790a9fbdbe041f14ca3a04e7393c4355da33d3b2501e3e168d306aa0232bdc4fcd2547e134 SHA512 553ed1eea1b8acd1da19be01a7ff7f9d420c9c8b03b38bcdab125f1f02dde6b164caea44019fc3557f8d61ae3f22da925e30dd858402841714d6c17462cff98e
+EBUILD puppet-5.5.2.ebuild 3835 BLAKE2B 578f7d7e2e5183069e2e172ac5e705c1dce0c16a67e1340ae0f59358451526ba80969c20b61964bc7b1f74e44f1282ff200f2e231e2da8b1330e054930e2f78b SHA512 ce9da2baad7e0cc36a206f4bd50922d514b99df41230462e128f0abc3df05a5aea4f736f4534a621b8b89d76946ef84ddf0b64c90a399e31b0988cfd3ffd7afb
MISC metadata.xml 1514 BLAKE2B 54902aeb644661563205d2200b71fdb6c0191839643968ae3249b1438996bc6b2846fbc4f9487dd83c28e9501407153fcc21255ad7ed6356aca3fb9121ab6abb SHA512 3ae8d47ac2a12085ec4adcb43d0428dc0b85fb561bbda39afd01ba7466417a24f9630d37c8461f99ec1aa3eb4f118cab0cb31703f486ab6d3a65798119277c64
diff --git a/app-admin/puppet/puppet-5.5.2.ebuild b/app-admin/puppet/puppet-5.5.2.ebuild
new file mode 100644
index 000000000000..1bbef6e53489
--- /dev/null
+++ b/app-admin/puppet/puppet-5.5.2.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit eutils user ruby-fakegem versionator
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ >=dev-ruby/facter-3.0.0
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # can't be run within portage.
+ epatch "${FILESDIR}/puppet-fix-tests-4.7.0.patch"
+
+ # fix systemd path
+ epatch "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+ newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+
+ for v in ${REPLACING_VERSIONS}; do
+ if [ "$(get_major_version $v)" = "4" ]; then
+ elog
+ elog "Please see the following url for the release notes for puppet-5"
+ elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
+ elog
+ fi
+ done
+}