summaryrefslogtreecommitdiff
path: root/app-admin/puppet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-27 22:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-27 22:00:51 +0100
commit14fff03b5545ac6b6f575afd2e6174afbd294fdd (patch)
tree21be5aee55de4f6216e406157ad8c59a811ea202 /app-admin/puppet
parent9f51c386724b9543e88a9c0e1be57d44326f3116 (diff)
gentoo auto-resync : 27:08:2023 - 22:00:51
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest2
-rw-r--r--app-admin/puppet/puppet-8.2.0.ebuild128
2 files changed, 130 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index ea1f61cfefc1..ce815cb331e4 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -3,6 +3,8 @@ AUX puppet.init 760 BLAKE2B 1803b602178f711cb4a0784a8e74e5bc63b66db11ce4a9855f76
AUX tmpfiles.d-2 35 BLAKE2B 333994788552e5c52273752f4e3c2947666737d03f9d340e16ada790607efe77da1ba9bb4852bc8274174fbb96ce0c7ae81062f7197e63ea4701e539b2650b3b SHA512 fdf00147c497bd822a14f0e42bad825a43ce0977ec6c0265d267dedeef56295e3ce319f7972d0ec2ab9f04f2407856947f4261d6e62054a36c6e1672b45f86f0
DIST puppet-7.24.0.tar.gz 2823083 BLAKE2B f4a3862153a01b1d5ce1cc9d72a2446d91346c5e8ed762f8aeae260a67bd583c277cd4ea0f207021057d40c69078add06af88978522706dea59796bdd6071070 SHA512 bb881e7523fce72ca8941d363ebc12f0172aff61a28d49465b7977fdf0d004575f5677fad3f0858db109b1cf85e4d870becdaa7c6687db32eb6eecf849ed25e9
DIST puppet-8.1.0.tar.gz 2877086 BLAKE2B 24fde48d04790ca308ef80ca51021b69dd08f703eec49724f753aabe36b824d338d135e985a5741b7e412f807ee35edf7898d2bc12d61bd9243e3fc1540808e2 SHA512 7811d67f83c72d67d5d463ccddece8889868f302217229f748a1d95df8b64213d9ee86a34e42af3beed9fc55cf70a14f63e6b8a6fcd18feb259e1d027dc35259
+DIST puppet-8.2.0.tar.gz 2882267 BLAKE2B b109e5cc9fddfa96ebc3be6b892d46a4616a5c1cec677937d02e16d0de6e39c147a9b117514e37ce29b39203f167a33dfe3a6c849fc7ebabecd48925b0d2595b SHA512 40e46350aadd19e187cc2a3c46cfa9f85bb2ffb944b0dcb18d084b10a8baca4c3c830e1361c840490c4f6257930a3ccb556d76b1a933e579ef37103556991b0e
EBUILD puppet-7.24.0.ebuild 3667 BLAKE2B 596aba703f8e8154cde0c6dd8d11cde9118aac72546a3579bfbe43e69748b80e89ffed85baf5e0be36f5cb3e969837fe731523827581a60535df6f43ba9a5691 SHA512 9db45b40a7c9b7367583181a28dc5901c845fe814298a48fe1fe2ea9b3d7eec9c55ab3076f934902f1c8885deffc89eac90e8fa13d6a4fdf16e313f031d3cc6f
EBUILD puppet-8.1.0.ebuild 3492 BLAKE2B 9712521f8dad46f304896c7abac0ecd4a39653226e597099707ea2f0589aa56bb1b80cb13fee68f6f243fed1db1a51c524ce4ce646722475bce4bc20524fda79 SHA512 7ea8b62f82ce1b0a5e17ea01c27caa62879141cc92b1b220dfdfe2a7d15cbd214db634e7642f83d60e9453ed056fa9d3f0ff998d5d4222f8aaed1cc262a4c65e
+EBUILD puppet-8.2.0.ebuild 3494 BLAKE2B 9c322edb607f4814aa571eea93d9a1f1f0ee34864e2272fd752f1ca3f9e88e58d74e96da62c5c35259b3da8c6b3f46155f2a703a797bfae39903a59874ab5d51 SHA512 9ad6923e8105dcea2d31202233106ac5c5b040b8e542a99b6acf4ff680b01bce90fdcea543ef47056c8c751a51dbf6e59fa40a4ab70ad4c2e282fd591b09c94d
MISC metadata.xml 1496 BLAKE2B cc2549141aaf5623f65be274fa8195fe6ee2826620050284ab0a7f60ba04832ecf8fe0e0890c470c98095946d1e4e7a0ef1fabd4d400c47d086fe173769f3d8c SHA512 1217b23c939409ae6cd15286b3304388893970276c80bf11284769946856ba1db20ea537fee5b7b2183305a24c88c926804e21f246f508e40cde41f45f1490bf
diff --git a/app-admin/puppet/puppet-8.2.0.ebuild b/app-admin/puppet/puppet-8.2.0.ebuild
new file mode 100644
index 000000000000..2e5cabc1c6fd
--- /dev/null
+++ b/app-admin/puppet/puppet-8.2.0.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_RUBY="ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit ruby-fakegem systemd tmpfiles
+
+DESCRIPTION="A system automation and configuration management software"
+HOMEPAGE="https://puppet.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE="augeas diff doc emacs hiera ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+# <dev-ruby/concurrent-ruby-1.2 for bug #900206
+# - https://tickets.puppetlabs.com/browse/PUP-11722 (workaround, pinning)
+# - https://tickets.puppetlabs.com/browse/PUP-11723 (bug for fixing the pinning)
+ruby_add_rdepend "
+ hiera? ( dev-ruby/hiera )
+ dev-ruby/json:=
+ dev-ruby/semantic_puppet
+ >=dev-ruby/facter-3.0.0
+ dev-ruby/deep_merge
+ <dev-ruby/concurrent-ruby-1.2
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0
+ acct-user/puppet
+ acct-group/puppet"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # fix systemd path
+ eapply -p0 "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" \
+# "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ newtmpfiles "${FILESDIR}/tmpfiles.d-2" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init puppet
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"
+ dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet.conf
+
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+}