summaryrefslogtreecommitdiff
path: root/app-admin/puppet-lint/puppet-lint-4.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-06 09:22:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-06 09:22:07 +0100
commit9b81b8a93760fc1c7d79561adbd7a62c82f334db (patch)
tree91cf0d90ea0a8fff253b43d0648c2d48649884e4 /app-admin/puppet-lint/puppet-lint-4.0.1.ebuild
parent681aad60df032a891dbbfc38f3ea4b404d6a8579 (diff)
gentoo auto-resync : 06:08:2023 - 09:22:07
Diffstat (limited to 'app-admin/puppet-lint/puppet-lint-4.0.1.ebuild')
-rw-r--r--app-admin/puppet-lint/puppet-lint-4.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/puppet-lint-4.0.1.ebuild b/app-admin/puppet-lint/puppet-lint-4.0.1.ebuild
new file mode 100644
index 000000000000..3925aec549db
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-4.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP="puppet-lint"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="https://github.com/puppetlabs/puppet-lint"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"
+
+all_ruby_prepare() {
+ # Skip acceptance tests due to unpackages puppet_litmus which in turn
+ # has a number of unpackaged dependencies.
+ rm -rf spec/acceptance || die
+ rm -f spec/spec_helper_acceptance.rb || die
+}