summaryrefslogtreecommitdiff
path: root/app-admin/puppet-lint/puppet-lint-2.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/puppet-lint/puppet-lint-2.3.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/puppet-lint/puppet-lint-2.3.2.ebuild')
-rw-r--r--app-admin/puppet-lint/puppet-lint-2.3.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/puppet-lint-2.3.2.ebuild b/app-admin/puppet-lint/puppet-lint-2.3.2.ebuild
new file mode 100644
index 000000000000..65e7f40bb291
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-2.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit eutils ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}