summaryrefslogtreecommitdiff
path: root/app-admin/ps_mem/ps_mem-3.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/ps_mem/ps_mem-3.12.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/ps_mem/ps_mem-3.12.ebuild')
-rw-r--r--app-admin/ps_mem/ps_mem-3.12.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ps_mem/ps_mem-3.12.ebuild b/app-admin/ps_mem/ps_mem-3.12.ebuild
new file mode 100644
index 000000000000..a60e22bad8fc
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/${PN}"
+SRC_URI="https://github.com/pixelb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${PYTHON_DEPS}"
+
+python_install() {
+ distutils-r1_python_install --install-scripts="/usr/sbin"
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman ${PN}.1
+}