summaryrefslogtreecommitdiff
path: root/app-admin/pass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:58:21 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:58:21 +0100
commit3811bc3072bf19e2be351d2c63f81532945c0f21 (patch)
tree52b4da2dd6e3e391c6d505db21bf24fbedd2cb6e /app-admin/pass
parent741f84b9049559581fdb52d1f8b93b5105c1187b (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'app-admin/pass')
-rw-r--r--app-admin/pass/Manifest1
-rw-r--r--app-admin/pass/pass-1.7.2-r1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/pass/Manifest b/app-admin/pass/Manifest
index d77642cd8165..348f26b5f767 100644
--- a/app-admin/pass/Manifest
+++ b/app-admin/pass/Manifest
@@ -1,5 +1,6 @@
AUX 50pass-gentoo.el 491 BLAKE2B 30c24a820e877e74d4308b42fab036c3c670353af6eb79454c18b471ab62134074765c313be5633e5fc8d1d9105a51d4dc648e3e08f200487ea62e3b9cd4e4a1 SHA512 eaba952f7b080bb44f1a415ee3fa1e71469177a993116b890a0788b177ec70948c1ea6923f17ddddf5f1c01af2fca03e98a71e06a5dff32ff6ebe0b73a79f659
DIST password-store-1.7.2.tar.xz 63620 BLAKE2B a1fe0b7ee1fdb94d2b76773653462d14c07c8fb239ffbcae210cc3c9c829fc5c0bd0bf85d8d44343a0cec50aae953b13a70d67aa7c94abf6c02f84bfd0d7c4ff SHA512 e6719a7125af6ecd80fdbeb38b4e2e89e7358ff16e18739d68a04b72dfdf860294b54f7ec0ec9676a62d2e270db8f54784a357c82217a478694472f8136e3657
+EBUILD pass-1.7.2-r1.ebuild 2158 BLAKE2B 5b975d3e64603dc81e5e899497c6eeaa27e8094cc3ff99895c5134b583cfe676f2e580a4a084f38f83c12fb3f4b1ca7ea73f2f84208e0db281578eb10b1d60de SHA512 e3c0d625d055b28f29f8a95a863b0b35be85bf7c847e117a54ffd992eff7aa890bd4c25ba9ef24caec81e7c750051a5a792194ee970fb31bded317d2c2db6d9f
EBUILD pass-1.7.2.ebuild 2056 BLAKE2B 45beac312a1acc149c67dac9801377f6722f5eff67a834e84e1a44fd5c7687a9f0c4f7e69fdca21b9cc070018ff2bf4e7dca1827222ce5261e5ed451c567b531 SHA512 27c994e62a3917be3ab836bff56e380cc3573a87ae62fabd8deba8c7e5b9b195812677799f378ff1290c39ef92e22922082761da59f7f24176fbcd811c73f918
EBUILD pass-9999.ebuild 1960 BLAKE2B e06b86833158fb55e9656a1bbc2168bbdfb0cc1fa48924437e2a05b81dc79c0f110cc2edf664610b43b29cb67c4563db568bbbf3cb6edd7f135b5db0d027751f SHA512 b170aaa7a41a628684735cd24994f40a95abd8e7c1ffa9bd52d381f4d94be246c7465cb617404eb61bc6221fede56f43dc76f18517329b83d00c0ebff02e4580
MISC metadata.xml 881 BLAKE2B 59fee6aeadb16d050eeaedc6d5081963e3ffa8316ddd00afb67661d721fa60b80483c16348e0c3d6c20fdb6513fd5840552c3a95724b619e07122d8755c4e7c1 SHA512 49df1e24751818d46a0c23fcdc9e41d965dca29f9964f7d142e4dba9b076b472c860d9b3eafc15b04a983f49d2cd78eb6b529742469549209c7e4160a15f1323
diff --git a/app-admin/pass/pass-1.7.2-r1.ebuild b/app-admin/pass/pass-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..370114ac6312
--- /dev/null
+++ b/app-admin/pass/pass-1.7.2-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 elisp-common
+
+DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
+HOMEPAGE="https://www.passwordstore.org/"
+SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
+
+RDEPEND="
+ app-crypt/gnupg
+ media-gfx/qrencode
+ >=app-text/tree-1.7.0
+ git? ( dev-vcs/git )
+ X? ( x11-misc/xclip )
+ elibc_Darwin? ( app-misc/getopt )
+ zsh-completion? ( app-shells/gentoo-zsh-completions )
+ fish-completion? ( app-shells/fish )
+ dmenu? ( x11-misc/dmenu x11-misc/xdotool )
+ emacs? ( virtual/emacs >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
+"
+
+S="${WORKDIR}/password-store-${PV}"
+
+src_prepare() {
+ default
+
+ use elibc_Darwin || return
+ # use coreutils'
+ sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
+ # host getopt isn't cool, and we aren't brew (rip out brew reference)
+ sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
+ # make sure we can find "mount"
+ sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
+}
+
+src_compile() {
+ use emacs && elisp-compile contrib/emacs/*.el
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ BASHCOMPDIR="$(get_bashcompdir)" \
+ WITH_BASHCOMP=yes \
+ WITH_ZSHCOMP=$(usex zsh-completion) \
+ WITH_FISHCOMP=$(usex fish-completion)
+ use dmenu && dobin contrib/dmenu/passmenu
+ if use emacs; then
+ elisp-install ${PN} contrib/emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ fi
+ if use importers; then
+ exeinto /usr/share/${PN}/importers
+ doexe contrib/importers/*
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use importers; then
+ einfo "To import passwords from other password managers, you may use the"
+ einfo "various importer scripts found in:"
+ einfo " ${EROOT%/}/usr/share/${PN}/importers/"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}