summaryrefslogtreecommitdiff
path: root/app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
commit2e34d110f164bf74d55fced27fe0000201b3eec5 (patch)
treef00ae60197c58f84ad51f60b210738d9b70f555b /app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild
parentf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (diff)
gentoo resync : 01.10.2020
Diffstat (limited to 'app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild')
-rw-r--r--app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild b/app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild
new file mode 100644
index 000000000000..a1bbc9ae0b9c
--- /dev/null
+++ b/app-admin/op-cli-bin/op-cli-bin-1.7.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="command line interface for the 1password password manager"
+HOMEPAGE="https://1password.com/downloads/command-line"
+SITE="https://cache.agilebits.com/dist/1P/op/pkg/v${PV}/"
+SRC_URI="${SITE}/op_linux_amd64_v${PV}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-arch/unzip"
+
+QA_PREBUILT="usr/bin/op"
+RESTRICT="bindist mirror"
+S="${WORKDIR}"
+
+src_install() {
+ dobin op
+}