summaryrefslogtreecommitdiff
path: root/app-admin/ngxtop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/ngxtop
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/ngxtop')
-rw-r--r--app-admin/ngxtop/Manifest6
-rw-r--r--app-admin/ngxtop/files/ngxtop-0.0.2-py3.patch45
-rw-r--r--app-admin/ngxtop/metadata.xml11
-rw-r--r--app-admin/ngxtop/ngxtop-0.0.2-r1.ebuild27
-rw-r--r--app-admin/ngxtop/ngxtop-0.0.3_pre141201.ebuild28
5 files changed, 117 insertions, 0 deletions
diff --git a/app-admin/ngxtop/Manifest b/app-admin/ngxtop/Manifest
new file mode 100644
index 000000000000..f4739ebfdd27
--- /dev/null
+++ b/app-admin/ngxtop/Manifest
@@ -0,0 +1,6 @@
+AUX ngxtop-0.0.2-py3.patch 1816 BLAKE2B 1f19b6143bc5eab4786043d1641f17a370cc07b72c3e61329e9b3255fb6a0c66d00d94b371aae5e0d5747e99964a102d7ea630a235ebad4df0cd3ff015917c95 SHA512 47127c5ba26d0d6319ca74f21370bf01ce3a74676066bf7476f862de8165c2d62d90e5cad1cb2369e5743db4fa51090e8bdf59da04f9dcfafec62edc44122f8f
+DIST ngxtop-0.0.2.tar.gz 9668 BLAKE2B becd0ba58490ad26dce2166ddf39d2064e797bc26da64b70e38e137078130f5c21a95fffccf656fcaa35ca595fe769bd4b59036e9e0993afa75d062b49714f10 SHA512 49cd0f43bb7dae79253a13c4011a5bb92a33c137d0ce7a8de7d57ba18624ec1e10bf462a32fe96d1045ed85ba9c273260a846fb1983e189884e65c1621a39d43
+DIST ngxtop-0.0.3_pre141201.tar.xz 9012 BLAKE2B 9e8a7d2c3aadb302e0923fc7cb5b0219a56489993fdcf83fb7b38ba67036f2b5cae7e5bba2c9efc81d858c58b0f1e25f17fa8cc600e77f76b45aafd9d5a3354e SHA512 ce0c6d027eacfe553752a4a66b7d5823de45ef847d4db1a50d9677126a1d574c22e17b5a60f073bf74eb93d56d15d88d6201353324b201b77c1dd5bede6d7cde
+EBUILD ngxtop-0.0.2-r1.ebuild 651 BLAKE2B 972956525ec3f24e35bfa4287ff3fa6404330047336269ff647acad3a48a5373514ccb4fc550673218e8993596fded2ae4f9a25b92d9ce01bf1483e9cfa2078b SHA512 77bad90097cb535f8e610a2498ec23e6c665adb943d7df7dfc1a20be8b938aa43fea0e295f97fb3219716c2652c9bddb33059f4df2c4dd6b4b2f50b33c7f2d99
+EBUILD ngxtop-0.0.3_pre141201.ebuild 728 BLAKE2B 1825345d92cf5f119af84477614bd910afaa251efc59318ea1fdfc60a361efdfece77d0d91aadf9cd45c9acbcc1dd7b155edf2c5a9827a1161ce424bac12a150 SHA512 b857066578c5c46f2bcbe0413f11e0996e0e4a9fdd932d3c2ebf9e4e24a9e003f54237b884d8b9588fd8d37ae21485476c4d7053c3c4bfcdb380e3f69809887c
+MISC metadata.xml 335 BLAKE2B e7a3dadd0a07d8bae375095732fd23ea9f95886f26acdf7fed053a2a75a799d37a6c64eb5ccf584fffc53a102ccf4925e10d95b146c8060275332f82858a1456 SHA512 6d525ce3c5a1efa8da1913ace611f778d2e0b7470521a970e26547ea921529a952576369f8fcfb19d39dea6222c0929ab475e5f7b0375d5ddf794a0303504ead
diff --git a/app-admin/ngxtop/files/ngxtop-0.0.2-py3.patch b/app-admin/ngxtop/files/ngxtop-0.0.2-py3.patch
new file mode 100644
index 000000000000..b86361584798
--- /dev/null
+++ b/app-admin/ngxtop/files/ngxtop-0.0.2-py3.patch
@@ -0,0 +1,45 @@
+diff --git a/ngxtop/config_parser.py b/ngxtop/config_parser.py
+index f6999cf..7c0d79a 100644
+--- a/ngxtop/config_parser.py
++++ b/ngxtop/config_parser.py
+@@ -106,7 +106,7 @@ def detect_log_config(arguments):
+
+ log_formats = dict(get_log_formats(config_str))
+ if len(access_logs) == 1:
+- log_path, format_name = access_logs.items()[0]
++ log_path, format_name = list(access_logs.items())[0]
+ if format_name == 'combined':
+ return log_path, LOG_FORMAT_COMBINED
+ if format_name not in log_formats:
+@@ -115,7 +115,7 @@ def detect_log_config(arguments):
+
+ # multiple access logs configured, offer to select one
+ print('Multiple access logs detected in configuration:')
+- log_path = choose_one(access_logs.keys(), 'Select access log file to process: ')
++ log_path = choose_one(list(access_logs.keys()), 'Select access log file to process: ')
+ format_name = access_logs[log_path]
+ if format_name not in log_formats:
+ error_exit('Incorrect format name set in config for access log file "%s"' % log_path)
+diff --git a/ngxtop/ngxtop.py b/ngxtop/ngxtop.py
+old mode 100755
+new mode 100644
+diff --git a/ngxtop/utils.py b/ngxtop/utils.py
+index ef61072..7bd9a2a 100644
+--- a/ngxtop/utils.py
++++ b/ngxtop/utils.py
+@@ -5,6 +5,8 @@ def choose_one(choices, prompt):
+ for idx, choice in enumerate(choices):
+ print('%d. %s' % (idx + 1, choice))
+ selected = None
++ if sys.version[0] == '3':
++ raw_input = input
+ while not selected or selected <= 0 or selected > len(choices):
+ selected = raw_input(prompt)
+ try:
+@@ -16,4 +18,4 @@ def choose_one(choices, prompt):
+
+ def error_exit(msg, status=1):
+ sys.stderr.write('Error: %s\n' % msg)
+- sys.exit(status)
+\ No newline at end of file
++ sys.exit(status)
diff --git a/app-admin/ngxtop/metadata.xml b/app-admin/ngxtop/metadata.xml
new file mode 100644
index 000000000000..629c4b1c7e91
--- /dev/null
+++ b/app-admin/ngxtop/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mattm@gentoo.org</email>
+ <name>Matthew Marlowe</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lebinh/ngxtop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/ngxtop/ngxtop-0.0.2-r1.ebuild b/app-admin/ngxtop/ngxtop-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..e187ef559f43
--- /dev/null
+++ b/app-admin/ngxtop/ngxtop-0.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="real-time metrics for nginx server (and others)"
+HOMEPAGE="https://github.com/lebinh/ngxtop"
+SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}"/${P}-py3.patch )
diff --git a/app-admin/ngxtop/ngxtop-0.0.3_pre141201.ebuild b/app-admin/ngxtop/ngxtop-0.0.3_pre141201.ebuild
new file mode 100644
index 000000000000..6bf6aa1b02f1
--- /dev/null
+++ b/app-admin/ngxtop/ngxtop-0.0.3_pre141201.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="real-time metrics for nginx server (and others)"
+HOMEPAGE="https://github.com/lebinh/ngxtop"
+#SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.0.2-py3.patch )