summaryrefslogtreecommitdiff
path: root/app-admin/mei-amt-check/mei-amt-check-0_p20170515.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/mei-amt-check/mei-amt-check-0_p20170515.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/mei-amt-check/mei-amt-check-0_p20170515.ebuild')
-rw-r--r--app-admin/mei-amt-check/mei-amt-check-0_p20170515.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/mei-amt-check/mei-amt-check-0_p20170515.ebuild b/app-admin/mei-amt-check/mei-amt-check-0_p20170515.ebuild
new file mode 100644
index 000000000000..e6400ff43960
--- /dev/null
+++ b/app-admin/mei-amt-check/mei-amt-check-0_p20170515.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vcs-snapshot linux-info toolchain-funcs
+
+DESCRIPTION="AMT status checker"
+HOMEPAGE="https://github.com/mjg59/mei-amt-check/"
+COMMIT="d07672120ce7a0c79e949e537f3d19efecec1700"
+SRC_URI="https://github.com/mjg59/mei-amt-check/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CONFIG_CHECK="~INTEL_MEI_ME"
+ERROR_INTEL_MEI_ME="Need to activate INTEL_MEI_ME to run the tool"
+
+src_prepare() {
+ default
+ sed -i -e "/CC :=/d" Makefile || die
+}
+
+src_compile() {
+ CC=$(tc-getCC) emake all
+}
+
+src_install() {
+ dosbin ${PN}
+ dodoc README.md
+}