summaryrefslogtreecommitdiff
path: root/app-admin/mcelog/mcelog-161.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /app-admin/mcelog/mcelog-161.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'app-admin/mcelog/mcelog-161.ebuild')
-rw-r--r--app-admin/mcelog/mcelog-161.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/mcelog/mcelog-161.ebuild b/app-admin/mcelog/mcelog-161.ebuild
new file mode 100644
index 000000000000..87b3afeab5c8
--- /dev/null
+++ b/app-admin/mcelog/mcelog-161.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A tool to log and decode Machine Check Exceptions"
+HOMEPAGE="http://mcelog.org/"
+SRC_URI="https://github.com/andikleen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-mcelog )"
+
+# TODO: add mce-inject to the tree to support test phase
+RESTRICT="test"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ local CONFIG_CHECK="~X86_MCE"
+ kernel_is -ge 4 12 && CONFIG_CHECK+=" ~X86_MCELOG_LEGACY"
+ check_extra_config
+ fi
+}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-0.8_pre1-timestamp-${PN}.patch \
+ "${FILESDIR}"/${PN}-129-debugflags.patch
+ eapply_user
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ insinto /etc/cron.daily
+ newins ${PN}.cron ${PN}
+
+ insinto /etc/logrotate.d/
+ newins ${PN}.logrotate ${PN}
+
+ newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ dodoc *.pdf
+}
+
+pkg_postinst() {
+ einfo "The default configuration set is now installed in /etc/${PN}"
+ einfo "you might want to edit those files."
+ einfo
+ einfo "A sample cronjob is installed into /etc/cron.daily"
+ einfo "without executable bit (system service is the preferred method now)"
+}