summaryrefslogtreecommitdiff
path: root/app-admin/longrun/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/longrun/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/longrun/files')
-rw-r--r--app-admin/longrun/files/0.9-makefile_cflags.patch13
-rw-r--r--app-admin/longrun/files/0.9-replace-loff_t.patch35
2 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/longrun/files/0.9-makefile_cflags.patch b/app-admin/longrun/files/0.9-makefile_cflags.patch
new file mode 100644
index 000000000000..8848dc667866
--- /dev/null
+++ b/app-admin/longrun/files/0.9-makefile_cflags.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,8 +2,8 @@
+
+ all: longrun README stamp-po
+
+-longrun: longrun.c
+- gcc -DLOCALEDIR=\"$(LOCALEDIR)\" -g -O2 -W -Wall -o longrun longrun.c
++CFLAGS += -W -Wall
++CPPFLAGS += -DLOCALEDIR=\"$(LOCALEDIR)\"
+
+ README: longrun.1
+ groff -Tascii -man longrun.1 | col -bx > README
diff --git a/app-admin/longrun/files/0.9-replace-loff_t.patch b/app-admin/longrun/files/0.9-replace-loff_t.patch
new file mode 100644
index 000000000000..589c0947b155
--- /dev/null
+++ b/app-admin/longrun/files/0.9-replace-loff_t.patch
@@ -0,0 +1,35 @@
+Use off_t instead of loff_t. Both pread() and pwrite() take
+off_t not loff_t types. This breaks the build on musl. See
+
+https://bugs.gentoo.org/show_bug.cgi?id=541694
+
+diff -Naur longrun.orig/longrun.c longrun/longrun.c
+--- longrun.orig/longrun.c 2015-03-07 19:05:19.166652462 +0000
++++ longrun/longrun.c 2015-03-07 19:06:05.419651899 +0000
+@@ -181,7 +181,7 @@
+ }
+
+ /* note: if an output is NULL, then don't set it */
+-void read_msr(loff_t address, int *lower, int *upper)
++void read_msr(off_t address, int *lower, int *upper)
+ {
+ uint32_t data[2];
+
+@@ -193,7 +193,7 @@
+ if (upper) *upper = data[1];
+ }
+
+-void write_msr(loff_t address, int lower, int upper)
++void write_msr(off_t address, int lower, int upper)
+ {
+ uint32_t data[2];
+
+@@ -206,7 +206,7 @@
+ }
+
+ /* note: if an output is NULL, then don't set it */
+-void read_cpuid(loff_t address, int *eax, int *ebx, int *ecx, int *edx)
++void read_cpuid(off_t address, int *eax, int *ebx, int *ecx, int *edx)
+ {
+ uint32_t data[4];
+