summaryrefslogtreecommitdiff
path: root/app-admin/logrotate/logrotate-3.15.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /app-admin/logrotate/logrotate-3.15.1.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'app-admin/logrotate/logrotate-3.15.1.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.15.1.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/app-admin/logrotate/logrotate-3.15.1.ebuild b/app-admin/logrotate/logrotate-3.15.1.ebuild
index ee5b360db5be..aa92d896ca49 100644
--- a/app-admin/logrotate/logrotate-3.15.1.ebuild
+++ b/app-admin/logrotate/logrotate-3.15.1.ebuild
@@ -1,28 +1,28 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit systemd
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="https://github.com/logrotate/logrotate"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="acl +cron selinux"
-CDEPEND="
+COMMON_DEPEND="
>=dev-libs/popt-1.5
selinux? ( sys-libs/libselinux )
acl? ( virtual/acl )"
-DEPEND="${CDEPEND}
+DEPEND="${COMMON_DEPEND}
>=sys-apps/sed-4"
-RDEPEND="${CDEPEND}
+RDEPEND="${COMMON_DEPEND}
selinux? ( sec-policy/selinux-logrotate )
cron? ( virtual/cron )"
@@ -34,7 +34,7 @@ move_old_state_file() {
elog "See bug #357275"
if [[ -e "${OLDSTATEFILE}" ]] ; then
elog "Moving your current state file to new location: ${STATEFILE}"
- mv -n "${OLDSTATEFILE}" "${STATEFILE}"
+ mv -n "${OLDSTATEFILE}" "${STATEFILE}" || die
fi
}
@@ -45,6 +45,7 @@ install_cron_file() {
PATCHES=(
"${FILESDIR}/${PN}-3.15.0-ignore-hidden.patch"
+ "${FILESDIR}/gcc-fnocommon.patch"
)
src_prepare() {
@@ -53,7 +54,10 @@ src_prepare() {
}
src_configure() {
- econf $(use_with acl) $(use_with selinux) --with-state-file-path="${STATEFILE}"
+ econf \
+ $(use_with acl) \
+ $(use_with selinux) \
+ --with-state-file-path="${STATEFILE}"
}
src_test() {