summaryrefslogtreecommitdiff
path: root/app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild')
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild b/app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild
new file mode 100644
index 000000000000..a33a27661666
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-1.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="amd64 x86"
+IUSE="libressl X +pinentry"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not include headers from /usr/local/include
+ sed -i -e 's:-I/usr/local/include::' Makefile || die
+ default
+ tc-export CC
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}/usr" COMPDIR="$(get_bashcompdir)" all doc-man
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install install-doc
+}