summaryrefslogtreecommitdiff
path: root/app-admin/lastpass-binary-component
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/lastpass-binary-component
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/lastpass-binary-component')
-rw-r--r--app-admin/lastpass-binary-component/Manifest4
-rw-r--r--app-admin/lastpass-binary-component/lastpass-binary-component-4.1.44.ebuild73
-rw-r--r--app-admin/lastpass-binary-component/metadata.xml20
3 files changed, 97 insertions, 0 deletions
diff --git a/app-admin/lastpass-binary-component/Manifest b/app-admin/lastpass-binary-component/Manifest
new file mode 100644
index 000000000000..d202dca25e37
--- /dev/null
+++ b/app-admin/lastpass-binary-component/Manifest
@@ -0,0 +1,4 @@
+DIST lastpass-binary-component-4.1.44.tar.bz2 1623477 SHA256 adb0e91f8d212d34dbb85db0b11738fe36db1a741ad5674d7070c4019a9fc75e SHA512 6fd518fa19f7206a1007376460c61e5a5c8d868126a767b3978309f0cc7ccd069e743cb12364e6841d8d3cb29452d058122b95f42bcfd2bd4deb4b8c77dc5f75 WHIRLPOOL c50bde0ee3f82abe56803beb2bda09786f7806b5e480eb8401fe0302ee984465f2682af66243095f3ea83744d59d6d3548806c423b69a8603abed9fc3ba3d00c
+EBUILD lastpass-binary-component-4.1.44.ebuild 1987 SHA256 65c0839b18ac887697fdc4953e14f00f4ff9dbb38e55bbf3c1b99794641f059f SHA512 65bf16de59b633847eef329c2e7333002c442332f86bc284577d0fc4fbd210adeaca455b65c70bc8fd62855198b74cbf4fbb32927b6c4ccd561032ea99147f6a WHIRLPOOL e8641d108f6450664ac461346d771572ed83866c0a189797847516697b83e488e74dbfcb302abb1d9f0fa053bb3dc2fbcceb2c08765500ecdd36b629be1f7ad6
+MISC ChangeLog 1109 SHA256 30bcd9c2fbbc86a284418d51db7de4a4f50308011c4292f7e7cc3a039555dde9 SHA512 59d411167317f3459c4cefb10b5e14ba4faea4c87f6acef301cf74c8d3c0a3377cc5e7233f0b72de4d75dd52507072f468227c44446177ade8d4653b323a0237 WHIRLPOOL b7a4cc7d6720577d1a2dd962dccb63ef44e97b4dc5d72843a984f1e1a8633a4e3cfb8b0daa5d8780737adb6840000117e0b2b742bdf32b870e5bbe642c279074
+MISC metadata.xml 816 SHA256 d35f43fbc54e2d23b6cfd6624949f28a85d3149c4405d83f739453111facb5a6 SHA512 71eb5c8aa836f75a5bfed79d7398e30628a274586a019d094a114d582ae2011d148cae325eb79b67e64035822cd18f154b9626142a7b2cc4c57f1e40f2f15b6b WHIRLPOOL 9b69c840104a8a72413892ad0f6bd9eba9534e14f5a7d8df5e3b7be88dbefd2b9f9eb21e513ef4f820c8c4de7f740c6d91e83546b6d2ad2cec146ba40813fe75
diff --git a/app-admin/lastpass-binary-component/lastpass-binary-component-4.1.44.ebuild b/app-admin/lastpass-binary-component/lastpass-binary-component-4.1.44.ebuild
new file mode 100644
index 000000000000..c46f9987de0a
--- /dev/null
+++ b/app-admin/lastpass-binary-component/lastpass-binary-component-4.1.44.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Binary component required by the LastPass Password Manager browser extension"
+HOMEPAGE="https://helpdesk.lastpass.com/downloading-and-installing/#h5"
+# sadly, upstream has no versioned distfiles
+SRC_URI="https://lastpass.com/lplinux.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LastPass"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+RESTRICT="strip mirror" # We can't mirror it, but we can fetch it
+
+RDEPEND="
+ !!app-admin/lastpass
+"
+
+LASTPASS_EXEDIR=/opt/lastpass/
+
+QA_PREBUILT="
+ ${LASTPASS_EXEDIR}nplastpass*
+"
+
+S="${WORKDIR}/lplinux"
+
+src_install() {
+ # This is based on the upstream installer script that's in the tarball
+ bin=nplastpass
+ use amd64 && bin="${bin}64"
+ exeinto ${LASTPASS_EXEDIR}
+ doexe "${S}"/${bin}
+
+ cat >"${T}"/lastpass_policy.json <<-EOF || die
+ {
+ "ExtensionInstallSources": [
+ "https://lastpass.com/*",
+ "https://*.lastpass.com/*",
+ "https://d1jxck0p3rkj0.cloudfront.net/lastpass/*"
+ ]
+ }
+ EOF
+ cat >"${T}"/com.lastpass.nplastpass.json <<-EOF || die
+ {
+ "name": "com.lastpass.nplastpass",
+ "description": "LastPass",
+ "path": "${LASTPASS_EXEDIR}${bin}",
+ "type": "stdio",
+ "allowed_origins": [
+ "chrome-extension://hdokiejnpimakedhajhdlcegeplioahd/",
+ "chrome-extension://debgaelkhoipmbjnhpoblmbacnmmgbeg/",
+ "chrome-extension://hnjalnkldgigidggphhmacmimbdlafdo/",
+ "chrome-extension://hgnkdfamjgnljokmokheijphenjjhkjc/"
+ ]
+ }
+ EOF
+
+ for d in /etc/chromium /etc/opt/chrome; do
+ insinto ${d}/policies/managed
+ doins "${T}"/lastpass_policy.json
+ insinto ${d}/native-messaging-hosts
+ doins "${T}"/com.lastpass.nplastpass.json
+ done
+
+}
+
+pkg_postinst() {
+ einfo "This package only installs the components required by the browser extension."
+ einfo "Visit the links below for your browser to install the extension itself:"
+ einfo "Chrome/Chromium: https://lastpass.com/dl/inline/?full=1"
+ einfo "Opera: https://lastpass.com/dl/"
+}
diff --git a/app-admin/lastpass-binary-component/metadata.xml b/app-admin/lastpass-binary-component/metadata.xml
new file mode 100644
index 000000000000..6f4f533e3c35
--- /dev/null
+++ b/app-admin/lastpass-binary-component/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <longdescription lang="en">
+ The binary features for Lastpass include faster encryption/decryption,
+ clipboard integration, smart card authentication and more for
+ <pkg>www-client/google-chrome</pkg>, <pkg>www-client/chromium</pkg>,
+ and <pkg>www-client/opera</pkg> web browsers. For
+ <pkg>www-client/firefox</pkg> this package is not required as the
+ extension bundles the binary components already.
+ </longdescription>
+</pkgmetadata>