summaryrefslogtreecommitdiff
path: root/app-admin/kube-bench/kube-bench-0.6.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-31 03:11:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-31 03:11:29 +0100
commit6262f7e48882f381dea4a0751717f65e6abd212f (patch)
treef50553545e7b75a3814a8190edab8ef1adcac9a3 /app-admin/kube-bench/kube-bench-0.6.8.ebuild
parentda7cbb075732f5f3eae5a42b6cf53d46caacf85c (diff)
gentoo auto-resync : 31:07:2022 - 03:11:29
Diffstat (limited to 'app-admin/kube-bench/kube-bench-0.6.8.ebuild')
-rw-r--r--app-admin/kube-bench/kube-bench-0.6.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/kube-bench/kube-bench-0.6.8.ebuild b/app-admin/kube-bench/kube-bench-0.6.8.ebuild
new file mode 100644
index 000000000000..4d7ff54265c5
--- /dev/null
+++ b/app-admin/kube-bench/kube-bench-0.6.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Kubernetes Bench for Security runs the CIS Kubernetes Benchmark"
+HOMEPAGE="https://github.com/aquasecurity/kube-bench"
+SRC_URI="https://github.com/aquasecurity/kube-bench/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 MIT MPL-2.0 BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake KUBEBENCH_VERSION=v${PV} build
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /etc/kube-bench
+ doins -r cfg
+}
+
+src_test() {
+ emake tests
+}