summaryrefslogtreecommitdiff
path: root/app-admin/keepassxc/keepassxc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-admin/keepassxc/keepassxc-9999.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-admin/keepassxc/keepassxc-9999.ebuild')
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 44ca0b85d8d9..6eb2c5dbb6e3 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,7 +8,7 @@ inherit cmake flag-o-matic xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
-if [[ "${PV}" != 9999 ]] ; then
+if [[ "${PV}" != *9999 ]] ; then
if [[ "${PV}" == *_beta* ]] ; then
SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/-}"
@@ -20,6 +20,7 @@ if [[ "${PV}" != 9999 ]] ; then
else
inherit git-r3
EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+ [[ "${PV}" != 9999 ]] && EGIT_BRANCH="master"
fi
LICENSE="LGPL-2.1 GPL-2 GPL-3"
@@ -29,9 +30,7 @@ IUSE="autotype browser ccache doc keeshare +network test yubikey"
RESTRICT="!test? ( test )"
RDEPEND="
- app-crypt/argon2:=
- dev-libs/libgcrypt:=
- >=dev-libs/libsodium-1.0.12:=
+ dev-libs/botan:2
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -45,11 +44,13 @@ RDEPEND="
autotype? (
dev-qt/qtx11extras:5
x11-libs/libX11
- x11-libs/libXi
x11-libs/libXtst
)
- keeshare? ( dev-libs/quazip:0= )
- yubikey? ( sys-auth/ykpers )
+ keeshare? ( sys-libs/zlib:=[minizip] )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
"
DEPEND="
@@ -63,10 +64,7 @@ BDEPEND="
"
src_prepare() {
- use test || \
- sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
-
- if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != 9999 ]] && [[ ! -f .version ]] ; then
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
printf '%s' "${PV}" > .version || die
fi
@@ -86,7 +84,6 @@ src_configure() {
-DWITH_XC_BROWSER="$(usex browser)"
-DWITH_XC_FDOSECRETS=ON
-DWITH_XC_KEESHARE="$(usex keeshare)"
- -DWITH_XC_KEESHARE_SECURE="$(usex keeshare)"
-DWITH_XC_NETWORKING="$(usex network)"
-DWITH_XC_SSHAGENT=ON
-DWITH_XC_UPDATECHECK=OFF
@@ -95,5 +92,8 @@ src_configure() {
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
+ if [[ "${PV}" != 9999 ]] ; then
+ mycmakeargs+=( -DWITH_XC_KEESHARE_SECURE="$(usex keeshare)" )
+ fi
cmake_src_configure
}