summaryrefslogtreecommitdiff
path: root/app-admin/keepassx/keepassx-2.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/keepassx/keepassx-2.0.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/keepassx/keepassx-2.0.2-r1.ebuild')
-rw-r--r--app-admin/keepassx/keepassx-2.0.2-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/keepassx/keepassx-2.0.2-r1.ebuild b/app-admin/keepassx/keepassx-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..8baf1a36ba4e
--- /dev/null
+++ b/app-admin/keepassx/keepassx-2.0.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils vcs-snapshot xdg
+
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
+HOMEPAGE="http://www.keepassx.org/"
+SRC_URI="https://www.keepassx.org/releases/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 ) BSD GPL-2 LGPL-2.1 LGPL-3+ CC0-1.0 public-domain || ( LGPL-2.1 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(CHANGELOG)
+
+src_prepare() {
+ xdg_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_TESTS="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ xdg_pkg_preinst
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_pkg_postrm
+}