summaryrefslogtreecommitdiff
path: root/app-admin/integrit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/integrit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/integrit')
-rw-r--r--app-admin/integrit/Manifest4
-rw-r--r--app-admin/integrit/files/integrit-4.1-fix-build-system.patch43
-rw-r--r--app-admin/integrit/integrit-4.1-r1.ebuild65
-rw-r--r--app-admin/integrit/metadata.xml8
4 files changed, 120 insertions, 0 deletions
diff --git a/app-admin/integrit/Manifest b/app-admin/integrit/Manifest
new file mode 100644
index 000000000000..83a96c76cac2
--- /dev/null
+++ b/app-admin/integrit/Manifest
@@ -0,0 +1,4 @@
+AUX integrit-4.1-fix-build-system.patch 1169 BLAKE2B 36b13162ea3a583968bda35ece1b4b1cc83871d4c2352ebcbffd079a9265d84b15e72d5e93f10e2404cd26e0622c666cb8b60e1cd53f207f0149a55814e10477 SHA512 4ed15ee8383e280b2d16d353f3401a058ad03c4ad84e4d0932ceec74391e04d266c2468270d2a08d299c57ee105f504c917fcf04b4ac07639bcba42e0fde84f6
+DIST integrit-4.1.tar.gz 271626 BLAKE2B 538a34c8e5c00e1be66ba35095be4d61402372ea7fd9ba9bfff9149c9a82c43d625ffb345fe84b7561100b31f2a2a1ba319e8b9a7d2b78e44a81d1ed6ae64f3a SHA512 599ae66a193fd87971994f59422e148e1ae01a5ff0fea93a0f2555c972f5254f0213116950766e72c87a57b1bd490f04afd3e0557d25a366c41dbbacc80b6842
+EBUILD integrit-4.1-r1.ebuild 1264 BLAKE2B 208f5ff74d53a189f7eabd131e3f032cff73d467e4622d317148d9a17c4b7db55335815ec6e59ba85794794bac1bff901dbd7d21b04e32ea0714fd3c7c54d5f1 SHA512 8cbb22064be0107ae5fa363185ccdecf347e7078a0d455d0af8af59b504282005816c1c52e3a01999568bb39a89e30043c48c556b6e78579c25dbc72afe8a5f4
+MISC metadata.xml 245 BLAKE2B 8edad0fa1051f1c6b28fa61e95cbde797389dcae4a23b953e0b77198a5557e068e09cdb6b2e32ca4e25ea07789c406529094d25fa74182656a4c59f4f7a42178 SHA512 e7052ee3572f1a5546b02087b7de95803a2e8b023aa24bc701eebb0bdd47b294d9634f4e78abfa10764e88397a067b1f1f8e431cddf5f8b260693f56ebd88b8b
diff --git a/app-admin/integrit/files/integrit-4.1-fix-build-system.patch b/app-admin/integrit/files/integrit-4.1-fix-build-system.patch
new file mode 100644
index 000000000000..64b3d47e59f8
--- /dev/null
+++ b/app-admin/integrit/files/integrit-4.1-fix-build-system.patch
@@ -0,0 +1,43 @@
+--- a/configure.in
++++ b/configure.in
+@@ -26,7 +26,6 @@
+
+ # ----- you can override these values by setting environment variables
+ # CC=my-compiler ./configure
+-CC=${CC:-"gcc"}
+ # CFLAGS="-g foo -x bar" ./configure
+ CFLAGS=${CFLAGS-"-g -Wall -O2"}
+ STATIC=${STATIC-"-static"}
+@@ -53,10 +52,9 @@
+ dnl AC_PROG_LEX
+ AC_PROG_MAKE_SET
+ AC_PROG_AWK
+-AC_PROGRAM_PATH(RM, rm , rm)
+ dnl syncing is the job of the O.S., and users can always do "make; sync"
+ dnl AC_PROGRAM_PATH(SYNC, sync, sync)
+-AC_PROGRAM_PATH(AR, ar, ar)
++AM_PROG_AR
+ AC_PROG_RANLIB
+
+ dnl ---------- let users override the install that configure finds
+--- a/hashtbl/configure.in
++++ b/hashtbl/configure.in
+@@ -25,17 +25,15 @@
+
+ # ----- you can override these values by setting environment variables
+ # CC=my-compiler ./configure
+-CC=${CC:-"gcc"}
+ # CFLAGS="-g foo -x bar" ./configure
+ CFLAGS=${CFLAGS:-"-g -Wall -O2"}
+ STATIC=${STATIC:-"-static"}
+
+ dnl Checks for programs.
+ AC_PROG_CC
+-AC_PROGRAM_PATH(RM, rm , rm)
+ dnl syncing is the job of the O.S., and users can always do "make; sync"
+ dnl AC_PROGRAM_PATH(SYNC, sync, sync)
+-AC_PROGRAM_PATH(AR, ar, ar)
++AM_PROG_AR
+ AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
+
diff --git a/app-admin/integrit/integrit-4.1-r1.ebuild b/app-admin/integrit/integrit-4.1-r1.ebuild
new file mode 100644
index 000000000000..bac0fe23c099
--- /dev/null
+++ b/app-admin/integrit/integrit-4.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="file integrity verification program"
+HOMEPAGE="http://integrit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${PN}-4.1-fix-build-system.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ mv hashtbl/configure.{in,ac} || die
+
+ # tests are not executable
+ chmod +x test/test || die
+
+ eautoreconf
+}
+
+src_compile() {
+ emake
+ emake utils
+
+ emake -C doc
+ emake -C hashtbl hashtest
+}
+
+src_install() {
+ dosbin integrit
+ dolib.a libintegrit.a
+ dodoc Changes HACKING README todo.txt
+
+ # utils
+ dosbin utils/i-viewdb
+ dobin utils/i-ls
+
+ # hashtbl
+ dolib.a hashtbl/libhashtbl.a
+ doheader hashtbl/hashtbl.h
+ dobin hashtbl/hashtest
+ newdoc hashtbl/README README.hashtbl
+
+ # doc
+ doman doc/{i-ls.1,i-viewdb.1,integrit.1}
+ doinfo doc/integrit.info
+
+ # examples
+ dodoc -r examples
+}
+
+pkg_postinst() {
+ elog "It is recommended that the integrit binary is copied to a secure"
+ elog "location and re-copied at runtime or run from a secure medium."
+ elog "You should also create a configuration file (see examples)."
+}
diff --git a/app-admin/integrit/metadata.xml b/app-admin/integrit/metadata.xml
new file mode 100644
index 000000000000..fa14c9a7ea90
--- /dev/null
+++ b/app-admin/integrit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">integrit</remote-id>
+ </upstream>
+</pkgmetadata>