summaryrefslogtreecommitdiff
path: root/app-admin/ide-smart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/ide-smart
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/ide-smart')
-rw-r--r--app-admin/ide-smart/Manifest5
-rw-r--r--app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch17
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r1.ebuild35
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r2.ebuild25
-rw-r--r--app-admin/ide-smart/metadata.xml5
5 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/ide-smart/Manifest b/app-admin/ide-smart/Manifest
new file mode 100644
index 000000000000..ead0b6dbe7ce
--- /dev/null
+++ b/app-admin/ide-smart/Manifest
@@ -0,0 +1,5 @@
+AUX ide-smart-1.4-fix-build-system.patch 280 BLAKE2B feac0eeafdc202a7f0074c6ca8c102f5602bcd1b9ec734e605d122464c9e782db1efd502677d415b1620090a82b5ee70755e25bf478700eb6b89d059a9ba5bf4 SHA512 7b27a8842d0ac7834d660f1ef46563a210a37e737c469cfae0ec07d18ae6fa523b6482f8fcba3f63247742c86215e01a35294ea664a416e7ffa92184c91b8c03
+DIST ide-smart-1.4.tar.gz 19739 BLAKE2B d9c94b53855628ea10ea563f709754e7f79e50d43e24f76ac3c6dc9b5bdee81a547e63c4583c3506cc899c7e761b59dfbea6bb121f39053cefcac20a984b8d3b SHA512 9ac5cd03b67731aba5371ec9edb3aabb7d3e3b3680552b14741106d8d5ffe5a1705ad379dd8df60b972f3e23f66ed35b98341544feb4b856912138ccac109660
+EBUILD ide-smart-1.4-r1.ebuild 691 BLAKE2B 365faf918071ed12a596f8cf029c6b9fdb5e76dee3e6dc0c0ba11fadf868aa2ab7c8ed8af06aa25b559e6a65f71dbecd606b9e3065aca481d8db49bfd679285e SHA512 6a54fb402a507937358b6ada716caf88e9335dd02c83cee489bb2c2dd026521361a2df821a1bea13dbd025929d318036ec1648135dbbee703b7c9e9d07f13ae1
+EBUILD ide-smart-1.4-r2.ebuild 578 BLAKE2B 3e2a0f1117551cf82bb72af0f43f942ecf50aaaf624f772860f290cd708c5c6da12fb30c7a3eba05cbed211da60d7dbff94ede73a4e6b37c240e78425240e830 SHA512 73367fa4439efb9d52688da838416762119314f7545cde96973c1e14cb090d0497f4f8391bd9398cbbff0d8a15ad9fe409fb77fe341b4dae1fd568cb805571a8
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch b/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
new file mode 100644
index 000000000000..ad523e36b3f9
--- /dev/null
+++ b/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
@@ -0,0 +1,17 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,13 +2,10 @@
+
+ #CC = gcc
+ PROF = -g0 -O2
+-CFLAGS = $(PROF) -Wall
+-LDFLAGS = $(PROF)
++CFLAGS += -Wall
+ TARGET = ide-smart
+ OBJECTS = ide-smart.o
+
+-ide-smart: $(OBJECTS)
+- $(CC) $(LDFLAGS) -o $(TARGET) $(OBJECTS)
+
+ all: ide-smart
+
diff --git a/app-admin/ide-smart/ide-smart-1.4-r1.ebuild b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
new file mode 100644
index 000000000000..5ffb6e04cbb2
--- /dev/null
+++ b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to read SMART information from harddiscs"
+HOMEPAGE="http://www.linalco.com/comunidad.html http://www.linux-ide.org/smart.html"
+SRC_URI="http://www.linalco.com/ragnar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4-fix-build-system.patch )
+
+src_prepare() {
+ default
+
+ # yes, the tarball includes pre-compiled
+ # object files and binaries
+ rm ${PN}{,.o} || die
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin ide-smart
+ doman ide-smart.8
+ einstalldocs
+}
diff --git a/app-admin/ide-smart/ide-smart-1.4-r2.ebuild b/app-admin/ide-smart/ide-smart-1.4-r2.ebuild
new file mode 100644
index 000000000000..d6ec39958880
--- /dev/null
+++ b/app-admin/ide-smart/ide-smart-1.4-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to read SMART information from harddiscs"
+HOMEPAGE="http://www.linalco.com/comunidad.html http://www.linux-ide.org/smart.html"
+SRC_URI="http://www.linalco.com/ragnar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c || die "compile"
+}
+
+src_install() {
+ dobin ide-smart || die
+ doman ide-smart.8
+ dodoc README
+}
diff --git a/app-admin/ide-smart/metadata.xml b/app-admin/ide-smart/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-admin/ide-smart/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>