summaryrefslogtreecommitdiff
path: root/app-admin/gixy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /app-admin/gixy
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'app-admin/gixy')
-rw-r--r--app-admin/gixy/Manifest3
-rw-r--r--app-admin/gixy/files/gixy-0.1.20-backports.patch76
-rw-r--r--app-admin/gixy/gixy-0.1.20-r1.ebuild (renamed from app-admin/gixy/gixy-0.1.20.ebuild)11
3 files changed, 82 insertions, 8 deletions
diff --git a/app-admin/gixy/Manifest b/app-admin/gixy/Manifest
index e5e5a06d98f4..a84b53982494 100644
--- a/app-admin/gixy/Manifest
+++ b/app-admin/gixy/Manifest
@@ -1,3 +1,4 @@
+AUX gixy-0.1.20-backports.patch 2169 BLAKE2B 1e34947b01988a676fd0bbc597613722fa98dc05011cd3dcf11fbc1315ae26fe536f34215a5f89bff414e458c75675631d78bf153ef4e9e4b5305c83a77c0129 SHA512 597f61611ac805f756c8020f823467a11260e4e09bb5c0499dd7ce4f203f89510fdbf0a5a5391856f122fefc5c32e5b3bb2e5feca155c79735b22d79a6001942
DIST gixy-0.1.20.tar.gz 710691 BLAKE2B 09043925d950a9a35de4df91ef3c2f9e5ca4458227320555a109e50d0838fb10ae22d086cdfc39c0d76bcd051c1a7e1d5e291354cc457cff398be8d164cbfde6 SHA512 d666e758c2746c201a11b67b4b99cee1bd3406085eb1c0aa9ae520b72d3a1273e09e3475226a6e54fbfbcefe65b3be0fc877e66cbaa81f384f757767852bc08e
-EBUILD gixy-0.1.20.ebuild 830 BLAKE2B 3e0dd5a5672dca0f4dd04889f31c0e1230d45cbf315efcbcb2460292af64dabc9cbf5d4175244b7937a241ded41cc90a787c916499589059bc53e44b6011a88f SHA512 dc55945c2782d6fe09e2ff921668f5bab669fa7581a8a14fcbc338ff2dccf3063697576244aa1f0a7124a1c4a7349986c86da6a9060e0f2f0d46c9a601f1a215
+EBUILD gixy-0.1.20-r1.ebuild 724 BLAKE2B 792c202d33715ff1c95c9fa44b5a4444bcf150a2f6cffa992ce1cb75411b901d35ed02a46cc43129d82e536162efa478f07707c39393b199222c340c1150593f SHA512 db2af8b947c116ee0a26b1c20f6666cde1149fc28c7b5e8148a8c1130c2e19b7a8a7c5c373f13e5de290c3b0a5bce9cdb388015c7114ad8c7f4060f135318f63
MISC metadata.xml 324 BLAKE2B f6f81a115f0e155af5bb5031ddf6e8fb5cdc293c83fd93c4fddc38b06074866b5755f76ec4836cc0736550142e2f3e6c41f105ddb32069862a984a39fa0345f3 SHA512 161132676a924c42219b89d8c994159c4e89cb44d5f7598652ad42e5b19ae799185e430adb9a266410ef1f8dd5ae9f39b8385bbc9aa9bfbf8285d399ac0d07d0
diff --git a/app-admin/gixy/files/gixy-0.1.20-backports.patch b/app-admin/gixy/files/gixy-0.1.20-backports.patch
new file mode 100644
index 000000000000..36c9cb693577
--- /dev/null
+++ b/app-admin/gixy/files/gixy-0.1.20-backports.patch
@@ -0,0 +1,76 @@
+diff --git a/gixy/core/regexp.py b/gixy/core/regexp.py
+index 7a96187..f360604 100644
+--- a/gixy/core/regexp.py
++++ b/gixy/core/regexp.py
+@@ -3,7 +3,11 @@ import logging
+ import re
+ import random
+ import itertools
+-from cached_property import cached_property
++
++try:
++ from functools import cached_property
++except ImportError:
++ from cached_property import cached_property
+
+ import gixy.core.sre_parse.sre_parse as sre_parse
+
+diff --git a/gixy/directives/block.py b/gixy/directives/block.py
+index 5e5b1ed..cc9bcb0 100644
+--- a/gixy/directives/block.py
++++ b/gixy/directives/block.py
+@@ -1,4 +1,7 @@
+-from cached_property import cached_property
++try:
++ from functools import cached_property
++except ImportError:
++ from cached_property import cached_property
+
+ from gixy.directives.directive import Directive
+ from gixy.core.variable import Variable
+diff --git a/gixy/parser/raw_parser.py b/gixy/parser/raw_parser.py
+index 6a30b7f..0f43308 100644
+--- a/gixy/parser/raw_parser.py
++++ b/gixy/parser/raw_parser.py
+@@ -1,7 +1,11 @@
+ import logging
+ import codecs
+ import six
+-from cached_property import cached_property
++
++try:
++ from functools import cached_property
++except ImportError:
++ from cached_property import cached_property
+
+ from pyparsing import (
+ Literal, Suppress, White, Word, alphanums, Forward, Group, Optional, Combine,
+diff --git a/requirements.txt b/requirements.txt
+index dbf6d5f..47a1b54 100644
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -1,6 +1,6 @@
+ pyparsing>=1.5.5
+-cached-property>=1.2.0
++cached-property>=1.2.0;python_version<"3.8"
+ argparse>=1.4.0
+ six>=1.1.0
+ Jinja2>=2.8
+-ConfigArgParse>=0.11.0
+\ No newline at end of file
++ConfigArgParse>=0.11.0
+diff --git a/setup.py b/setup.py
+index e4314a6..e57842b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -18,8 +18,8 @@ setup(
+ url='https://github.com/yandex/gixy',
+ install_requires=[
+ 'pyparsing>=1.5.5',
+- 'cached-property>=1.2.0',
+- 'argparse>=1.4.0',
++ 'cached-property>=1.2.0;python_version<"3.8"',
++ 'argparse>=1.4.0;python_version<"3.2"',
+ 'six>=1.1.0',
+ 'Jinja2>=2.8',
+ 'ConfigArgParse>=0.11.0'
diff --git a/app-admin/gixy/gixy-0.1.20.ebuild b/app-admin/gixy/gixy-0.1.20-r1.ebuild
index a8d8b10d8ad4..806f19111532 100644
--- a/app-admin/gixy/gixy-0.1.20.ebuild
+++ b/app-admin/gixy/gixy-0.1.20-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-
inherit distutils-r1
DESCRIPTION="Nginx configuration static analyzer"
@@ -18,14 +17,12 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="
>=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
- >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.11.0[${PYTHON_USEDEP}]
>=dev-python/jinja-2.8[${PYTHON_USEDEP}]
>=dev-python/six-1.1.0[${PYTHON_USEDEP}]"
distutils_enable_tests nose
-python_prepare_all() {
- sed -i -e "/argparse/d" setup.py || die
- distutils-r1_python_prepare_all
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-backports.patch
+)