summaryrefslogtreecommitdiff
path: root/app-admin/gixy/gixy-0.1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /app-admin/gixy/gixy-0.1.8.ebuild
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'app-admin/gixy/gixy-0.1.8.ebuild')
-rw-r--r--app-admin/gixy/gixy-0.1.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/gixy/gixy-0.1.8.ebuild b/app-admin/gixy/gixy-0.1.8.ebuild
new file mode 100644
index 000000000000..4ade6ac258d8
--- /dev/null
+++ b/app-admin/gixy/gixy-0.1.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx configuration static analyzer"
+HOMEPAGE="https://github.com/yandex/gixy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.1.0[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+python_prepare() {
+ sed -i -e "/argparse/d" setup.py || die
+ distutils-r1_python_prepare_all
+}