summaryrefslogtreecommitdiff
path: root/app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch')
-rw-r--r--app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch b/app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch
new file mode 100644
index 000000000000..53c05d85f74c
--- /dev/null
+++ b/app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -23,8 +23,8 @@
+ ### compiler
+
+ ### gcc
+-CC=gcc
+-CFLAGS= -O -Werror -Wall -Wcast-qual -Wstrict-prototypes \
++CC ?= gcc
++CFLAGS += -Wall -Wcast-qual -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations -Winline -Wcast-align
+ ### cc
+ #CC=cc
+@@ -72,7 +72,7 @@
+
+ # compiler stuff
+ # --------------
+-CC_OPT= $(CFLAGS) -DFETCHLOG_VERSION_NO=\"$(FETCHLOG_VERSION)\" \
++CPPFLAGS += -DFETCHLOG_VERSION_NO=\"$(FETCHLOG_VERSION)\" \
+ $(HAS_MADVISE) $(HAS_REGEX)
+
+ # all
+@@ -82,7 +82,6 @@
+ # fetchlog
+ # -------
+ fetchlog: fetchlog.c
+- $(CC) $(CC_OPT) fetchlog.c -o fetchlog
+
+
+ # install