summaryrefslogtreecommitdiff
path: root/app-admin/fam/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/fam/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/fam/files')
-rw-r--r--app-admin/fam/files/fam-2.7.0-out-of-tree.patch13
-rw-r--r--app-admin/fam/files/fam-2.7.0-sysmacros.patch15
-rw-r--r--app-admin/fam/files/famd26
3 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/fam/files/fam-2.7.0-out-of-tree.patch b/app-admin/fam/files/fam-2.7.0-out-of-tree.patch
new file mode 100644
index 000000000000..51fdadf38fe6
--- /dev/null
+++ b/app-admin/fam/files/fam-2.7.0-out-of-tree.patch
@@ -0,0 +1,13 @@
+fix out of tree builds
+
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -7,7 +7,7 @@
+ Client.h \
+ fam.c++
+
+-libfam_la_LDFLAGS = -export-symbols fam.sym
++libfam_la_LDFLAGS = -export-symbols $(srcdir)/fam.sym
+ libfam_la_LIBADD = -lstdc++
+
+ EXTRA_DIST = fam.sym
diff --git a/app-admin/fam/files/fam-2.7.0-sysmacros.patch b/app-admin/fam/files/fam-2.7.0-sysmacros.patch
new file mode 100644
index 000000000000..ac42dca3bea6
--- /dev/null
+++ b/app-admin/fam/files/fam-2.7.0-sysmacros.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/580702
+
+fix build with newer glibc where sys/sysmacros.h isn't implicitly included
+by sys/types.h
+
+--- a/src/DNotify.c++
++++ b/src/DNotify.c++
+@@ -32,6 +32,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <libgen.h>
diff --git a/app-admin/fam/files/famd b/app-admin/fam/files/famd
new file mode 100644
index 000000000000..da3d745b244a
--- /dev/null
+++ b/app-admin/fam/files/famd
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+
+ need portmap
+
+}
+
+start() {
+
+ ebegin "Starting famd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/famd \
+ -- -T 0 -c /etc/fam.conf
+ eend $?
+
+}
+
+stop() {
+
+ ebegin "Stopping famd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/famd
+ eend $?
+
+}