summaryrefslogtreecommitdiff
path: root/app-admin/entr/entr-3.9-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
commita5956e0a0daddcad648e0d8d8e5cb3e49e09bda7 (patch)
tree3d2e0a61f348a5299e73ca7c2b236156a8cc79b5 /app-admin/entr/entr-3.9-r1.ebuild
parent38f60b3ec9ff175535d9a056a76ae42931e61e21 (diff)
gentoo resync : 18.11.2017
Diffstat (limited to 'app-admin/entr/entr-3.9-r1.ebuild')
-rw-r--r--app-admin/entr/entr-3.9-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/entr/entr-3.9-r1.ebuild b/app-admin/entr/entr-3.9-r1.ebuild
new file mode 100644
index 000000000000..a0df05becf54
--- /dev/null
+++ b/app-admin/entr/entr-3.9-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="http://entrproject.org"
+SRC_URI="http://entrproject.org/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="test"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mv eradman-* "${P}" || die
+}
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_compile() {
+ export CC=$(tc-getCC)
+ default
+}
+
+src_test() {
+ export CC=$(tc-getCC)
+ default
+}