summaryrefslogtreecommitdiff
path: root/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild')
-rw-r--r--app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild
new file mode 100644
index 000000000000..5e2638f231a1
--- /dev/null
+++ b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit ruby-single versionator
+
+DESCRIPTION="Command-line tools that serve as client interface to the Amazon EC2 web service"
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=368&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${P}.zip"
+
+LICENSE="Amazon
+ || ( Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ ${RUBY_DEPS}
+ virtual/ruby-ssl
+ net-misc/rsync
+ net-misc/curl"
+
+src_prepare() {
+ # Remove a left behind license file.
+ rm -f lib/ec2/oem/LICENSE.txt || die 'Removal of LICENSE failed.'
+
+ eapply_user
+}
+
+src_install() {
+ dobin bin/*
+
+ insinto /usr
+ doins -r lib
+
+ insinto /etc/ec2/amitools
+ doins etc/ec2/amitools/*
+
+ dodir /etc/env.d
+ echo "EC2_AMITOOL_HOME=/usr" >> "${T}"/99${PN} || die "Can't write environment variable."
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}