summaryrefslogtreecommitdiff
path: root/app-admin/dxf/dxf-6.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /app-admin/dxf/dxf-6.2.0.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'app-admin/dxf/dxf-6.2.0.ebuild')
-rw-r--r--app-admin/dxf/dxf-6.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/dxf/dxf-6.2.0.ebuild b/app-admin/dxf/dxf-6.2.0.ebuild
new file mode 100644
index 000000000000..4c3842e34cc1
--- /dev/null
+++ b/app-admin/dxf/dxf-6.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Docker registry v2 client in Python"
+HOMEPAGE="https://github.com/davedoesdev/dxf"
+SRC_URI="https://github.com/davedoesdev/dxf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/jwcrypto-0.4.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.10.0[${PYTHON_USEDEP}]
+ >=dev-python/www-authenticate-0.9.2[${PYTHON_USEDEP}]"
+
+RESTRICT="test"
+# Require dockerd running
+
+python_test() {
+ emake test
+}