summaryrefslogtreecommitdiff
path: root/app-admin/diradm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/diradm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/diradm')
-rw-r--r--app-admin/diradm/Manifest3
-rw-r--r--app-admin/diradm/diradm-2.9.7.1.ebuild68
-rw-r--r--app-admin/diradm/metadata.xml12
3 files changed, 83 insertions, 0 deletions
diff --git a/app-admin/diradm/Manifest b/app-admin/diradm/Manifest
new file mode 100644
index 000000000000..8a28a9dfaea3
--- /dev/null
+++ b/app-admin/diradm/Manifest
@@ -0,0 +1,3 @@
+DIST diradm-2.9.7.1.tar.bz2 126172 BLAKE2B 23f18a7946187caf1e12ec9d1f67a2c5c06895d837add3c79dd0b043d4745f0fd9b405e5667ebe5480946e4741c7bbff2be8c4281afcb7636353f72904f7e39b SHA512 5052f7b7072cd61eb9c70d23057f6c0d2fa68a151792d7260ca52716c9588c06234d335af84b967df23da4b4a8650502cab3b18900dc15e71f71b0888224993f
+EBUILD diradm-2.9.7.1.ebuild 1707 BLAKE2B b006d5606650f6b1b11a165aa5f951d4593d6f2b479040b6d7955e731da352c6321c9b8bb654778742e9454df77e333a7413f3d8f1818b6bf369719bfd89ae6a SHA512 821bcdaaa0b0db69d658436e93ca400b57583b1081964ed199800c1b0ab04e9fc01052ae1ea0d038f6e0ee37f889db213b824fb5d1615e85cc770f09b190e147
+MISC metadata.xml 409 BLAKE2B 9228d543861d197474a3a1e7a698b4c14fa702cc1c7454b0ceb7fcbe3b6cccc5b4d3695efb917d0d65b6907c7447a93f63412a09496048dda0a716c65160a5a6 SHA512 e9324ac84f7909c5972a7bc60d81cccddf03509f2809387b9819c67d48dfaaf080377cd6d9c624f3315bf8548a3b764d077e42636d8f51695a1837a9ebb26fb2
diff --git a/app-admin/diradm/diradm-2.9.7.1.ebuild b/app-admin/diradm/diradm-2.9.7.1.ebuild
new file mode 100644
index 000000000000..2d6459346171
--- /dev/null
+++ b/app-admin/diradm/diradm-2.9.7.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP"
+#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
+#SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+HOMEPAGE="http://orbis-terrarum.net/~robbat2/"
+SRC_URI="http://orbis-terrarum.net/~robbat2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="automount irixpasswd samba test"
+REQUIRED_USE="test? ( automount irixpasswd samba )"
+
+RDEPEND=">=net-nds/openldap-2.3
+ sys-apps/gawk
+ sys-apps/coreutils
+ sys-apps/grep
+ dev-lang/perl
+ app-shells/bash:*
+ sys-apps/sed
+ virtual/perl-MIME-Base64
+ samba? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ )"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ dev-util/dejagnu
+ net-nds/openldap[-minimal]
+ )"
+
+src_configure() {
+ econf \
+ $(use_enable automount) \
+ $(use_enable irixpasswd) \
+ $(use_enable samba)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ dodoc CHANGES.prefork KNOWN-BUGS
+
+ if use irixpasswd; then
+ insinto /etc/openldap/schema
+ doins irixpassword.schema
+ fi
+}
+
+pkg_postinst() {
+ elog "The new diradm pulls many settings from your LDAP configuration."
+ elog "But don't forget to customize /etc/diradm.conf for other settings."
+ elog "Please see the README to instructions if you problems."
+ elog "This package is primarily intended for use with nss_ldap & pam_ldap"
+ elog "and populates many default settings from the /etc/ldap.conf used by"
+ elog "those packages, with a further fallback to /etc/openldap/ldap.conf"
+ elog "for server connection settings only."
+}
diff --git a/app-admin/diradm/metadata.xml b/app-admin/diradm/metadata.xml
new file mode 100644
index 000000000000..151029fd4445
--- /dev/null
+++ b/app-admin/diradm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <use>
+ <flag name="automount">Support for automount data in LDAP</flag>
+ <flag name="irixpasswd">Support for storing separate IRIX passwords</flag>
+ </use>
+</pkgmetadata>