summaryrefslogtreecommitdiff
path: root/app-admin/dio/dio-1.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/dio/dio-1.5.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/dio/dio-1.5.2.ebuild')
-rw-r--r--app-admin/dio/dio-1.5.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/dio/dio-1.5.2.ebuild b/app-admin/dio/dio-1.5.2.ebuild
new file mode 100644
index 000000000000..6087eb8c5354
--- /dev/null
+++ b/app-admin/dio/dio-1.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="dio - Device I/O monitoring tool"
+HOMEPAGE="https://github.com/donaldmcintosh/dio"
+SRC_URI="https://github.com/donaldmcintosh/dio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin dio
+ doman dio.1
+}