summaryrefslogtreecommitdiff
path: root/app-admin/cpulimit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
commit2a8d2f71d1d9963368e0ef3d641d75979a689d12 (patch)
tree83e283f960ab2ebbc1a042b8ed6c37b78d47b37b /app-admin/cpulimit
parent8435c842b9e8fbb2bcc80397ab3aa655000459e2 (diff)
gentoo auto-resync : 04:07:2024 - 08:06:07
Diffstat (limited to 'app-admin/cpulimit')
-rw-r--r--app-admin/cpulimit/Manifest3
-rw-r--r--app-admin/cpulimit/cpulimit-3.1.ebuild27
-rw-r--r--app-admin/cpulimit/files/cpulimit-3.1-makefile.patch25
3 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/cpulimit/Manifest b/app-admin/cpulimit/Manifest
index 7265f42bb23a..7cb6c3ba6ca8 100644
--- a/app-admin/cpulimit/Manifest
+++ b/app-admin/cpulimit/Manifest
@@ -1,5 +1,8 @@
AUX cpulimit-2.8-inline-func.patch 454 BLAKE2B 282733b42c9e1ec1e7d39e28b4830912be9b636734086e78a32e5c8490fb906f9e88ac4edec3891d926e7a8f8227f0384811f1849c228fab39a620cafaec3e8b SHA512 727d548964e4ce3d81131ed113067666c4c6dc21306e9698efb6d7b6f2aceb6079a09ddbe6c6f9c10b40593dc6f769850bf2d9df6aac0bd3b8a4a3fa6c42d873
AUX cpulimit-2.8-makefile.patch 599 BLAKE2B 2b0f138ee0a30ce8a1e84b15c949c4c7176703968da326801672d98851b1ad4185ce5b6c9a6259a67e0de57b0b29b95fe96daf6e354b6c73cdf9b78fd5689ca2 SHA512 2d25fdbfa47f37d98592b1197f3877de6bbbbd40b975fa18163aa2d23ec32d13efe311736df0c68a8510219423d4673ef6e123a932300ae79d476efa119a0dca
+AUX cpulimit-3.1-makefile.patch 599 BLAKE2B 2b0f138ee0a30ce8a1e84b15c949c4c7176703968da326801672d98851b1ad4185ce5b6c9a6259a67e0de57b0b29b95fe96daf6e354b6c73cdf9b78fd5689ca2 SHA512 2d25fdbfa47f37d98592b1197f3877de6bbbbd40b975fa18163aa2d23ec32d13efe311736df0c68a8510219423d4673ef6e123a932300ae79d476efa119a0dca
DIST cpulimit-2.8.tar.gz 24860 BLAKE2B 6d4002d2cbc46da9ce102da77b701e6a99c2e7d16e2e7989baa1e07ef335b126a8c717c4779d121aee1e580ebf057a16b4f83c1bc6a29c904a7532debc4c490a SHA512 aeb121739a5dc9f94c6ddb0905ed05eb7d146c9d0e71c34ba46aad798bda2c30b7ccc548338b4c468f9885f09d97a4565c00199c8df6af74dc9b6f23940c540e
+DIST cpulimit-3.1.tar.gz 25446 BLAKE2B 77a7ca7dfbcb49f1db481e937607bfa3e287b944d741409033e0a93d2ec788024c30e4de0dc9270645dbd91a66b88db3ddc8763b41f2117b4176bb0f9c2aed5d SHA512 d4c8a2598535ba1221e2089c21576062eff47fe7e842f021e1db83ebdf7ad98ba7d6b216d4f2a93697d4e0adc54c281d24eded7d67bb83134ce06510e1389cda
EBUILD cpulimit-2.8.ebuild 592 BLAKE2B 4b05a800de3dc11ab5175d8171839047d65c6bdd2378cd5f346a932c1f368c86ae65a2bb3916a9993a4e0627f7df748944ed296d5f1fd10d7a6cab6371f3fdff SHA512 71567b23e1129c065889fc4b4e120368324bb755111e8df0884f9901e3031d84b9e718cff8991d49280aca5e22aba42eeecb1a96876f7fcce0a84e8ee118e60c
+EBUILD cpulimit-3.1.ebuild 542 BLAKE2B 1d2714103345d6b79da8d450daf83b428415b0d9ef1487c01e78efa6db972d8028ee9ad20e2846f7dd70223deaccd710247daf024627353fa23ea83fde4cd78d SHA512 0cfdd2257025bfd1c9ead363afcfb720cdba04b1076643343677eed74687c19a3c2496f61311bfed076dff050c2ece0502cee683419e74b7466fe298af18ac75
MISC metadata.xml 246 BLAKE2B f8eaf18c2348bc96406ed9c74b65064db04104fda3d02be7c4263042d973d0cd5b4aa34f7fa71217ab29ce1759feaf015fcfa886add91fc26b372c9071afb6a7 SHA512 6895874d4b7df644a526fc2919b75ac1786e3efbba42127b05af21f8e1fa3fa496def26e4ccb461d669ff6fa539a92c618cba4f7acda1f7bed43dcb11a11ba56
diff --git a/app-admin/cpulimit/cpulimit-3.1.ebuild b/app-admin/cpulimit/cpulimit-3.1.ebuild
new file mode 100644
index 000000000000..8f369c8795a2
--- /dev/null
+++ b/app-admin/cpulimit/cpulimit-3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Limits the CPU usage of a process"
+HOMEPAGE="https://cpulimit.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/limitcpu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc CHANGELOG README
+}
diff --git a/app-admin/cpulimit/files/cpulimit-3.1-makefile.patch b/app-admin/cpulimit/files/cpulimit-3.1-makefile.patch
new file mode 100644
index 000000000000..7daf8a7092ab
--- /dev/null
+++ b/app-admin/cpulimit/files/cpulimit-3.1-makefile.patch
@@ -0,0 +1,25 @@
+--- a/Makefile 2023-02-06 18:47:21.311693323 +0300
++++ b/Makefile 2023-02-06 18:48:23.392517904 +0300
+@@ -2,6 +2,7 @@
+ PREFIX?=/usr
+ CFLAGS?=-Wall -O2
+ CC?=clang
++DESTDIR=
+
+ all: cpulimit
+
+@@ -21,10 +22,10 @@
+ $(MAKE) -C test
+
+ install: cpulimit
+- mkdir -p ${PREFIX}/bin
+- mkdir -p ${PREFIX}/share/man/man1
+- cp cpulimit ${PREFIX}/bin
+- cp cpulimit.1 ${PREFIX}/share/man/man1
++ mkdir -p ${DESTDIR}/${PREFIX}/bin
++ mkdir -p ${DESTDIR}/${PREFIX}/share/man/man1
++ cp cpulimit ${DESTDIR}/${PREFIX}/bin
++ cp cpulimit.1 ${DESTDIR}/${PREFIX}/share/man/man1
+
+ deinstall:
+ rm -f ${PREFIX}/bin/cpulimit