summaryrefslogtreecommitdiff
path: root/app-admin/consolehm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/consolehm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/consolehm')
-rw-r--r--app-admin/consolehm/Manifest4
-rw-r--r--app-admin/consolehm/consolehm-1.31.ebuild47
-rw-r--r--app-admin/consolehm/files/consolehm-gcc4.patch10
-rw-r--r--app-admin/consolehm/metadata.xml8
4 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/consolehm/Manifest b/app-admin/consolehm/Manifest
new file mode 100644
index 000000000000..d40d5eb68b5d
--- /dev/null
+++ b/app-admin/consolehm/Manifest
@@ -0,0 +1,4 @@
+AUX consolehm-gcc4.patch 250 BLAKE2B 645d4a4aee3dd5a693b4528ef842b7aeca9369aa1574175c2e96b2fc5e05bccc961a6c1bd8bcb74902a911e1a6f1ad57095eec454fe989bbc5075ad7f297ce51 SHA512 d9d74aed3961073c2356ce30296635e000e8c9b0ab27b1b860d6a9ee30dd49c0e7ac9fea8c4f21118c36e3973ede0a07b14afd6da2506a0762fdafb89abcccbb
+DIST consolehm-1.31.tar.gz 21615 BLAKE2B e2e90628026eb5936b346bc6ee072f23e9dacdf4f028612d647771f6cb23b816a18a4f139ff7cf6c2333fd6cda133bd7220929113f6d77993e7073ec8086b1ec SHA512 595a5808bf85b878254e10fbe9a7beccffb4e5a35e03fe9fbea710963733fb4d6afe6fe6b70b30fa2b4fd565ed4ac1ffcca624b6717cc3b6d900960e7e6001f8
+EBUILD consolehm-1.31.ebuild 1027 BLAKE2B c47dd43e3aac39d882b2361d61cd5c5b89580df0b752f13e5df3d80601cfae183289b73d2d727b03da20127b463cfe648ec38c7e12e70b20bb3d38410cda266a SHA512 18f4e3d33fb3b439973c0d6dbdf5b14fc8d26e6ad5c073b884e9ee28bfe958394d715f4cd99bc53348dd38d1e42ea9bf35da70a970e3d8966d6f56254984f25d
+MISC metadata.xml 238 BLAKE2B 5d18b211ca67cdae4e0f4d6e1598b20b39a471aa07326791c53bb4e1013607b85bac28a64c1939e53b01228d0c9b7814314b95c0f76928de265d95ef7ee6cd45 SHA512 173efaa53a514acf1e2f0c6681c82a48ec16d505844f551d2cc823ee8685b27837c7461f7956c12182059ee7e83023e2f0bcd5d1afab74beeaf998487193656d
diff --git a/app-admin/consolehm/consolehm-1.31.ebuild b/app-admin/consolehm/consolehm-1.31.ebuild
new file mode 100644
index 000000000000..5fe3da38f115
--- /dev/null
+++ b/app-admin/consolehm/consolehm-1.31.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils
+
+DESCRIPTION="Console based hardware monitor for FreeBSD"
+HOMEPAGE="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/fenner/"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/fenner/${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~x86-fbsd"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-gcc4.patch || die "patch failed"
+ export CHMS="${S}/consolehm"
+ # The only 'SMBus' smb.h i've found is in a different place:
+ cd "${S}/consolehm"
+ sed -i.orig -e 's:machine/smb.h:dev/smbus/smb.h:g' \
+ configure.in \
+ configure \
+ chm.h || die "sed failed."
+}
+
+src_compile() {
+ cd "${S}/consolehm"
+ econf || die "econf failed"
+ MAKE=make emake || die "emake failed"
+}
+
+src_install() {
+ dobin "${S}/consolehm/chm"
+ doman "${S}/consolehm/chm.8"
+ dodoc "${S}"/CHANGELOG
+ dodoc "${S}"/README
+ dodoc "${S}"/TODO
+}
diff --git a/app-admin/consolehm/files/consolehm-gcc4.patch b/app-admin/consolehm/files/consolehm-gcc4.patch
new file mode 100644
index 000000000000..85f677a29cbf
--- /dev/null
+++ b/app-admin/consolehm/files/consolehm-gcc4.patch
@@ -0,0 +1,10 @@
+--- consolehm/consolehm/chm.c.orig 2000-12-23 03:51:45 -0300
++++ consolehm/consolehm/chm.c 2007-01-12 11:18:27 -0300
+@@ -165,6 +165,7 @@
+ printf("Delay: %d microseconds. \n\n",delay);
+ break;
+ default:
++ ;;
+ }
+
+ file_handle = OpenIO();
diff --git a/app-admin/consolehm/metadata.xml b/app-admin/consolehm/metadata.xml
new file mode 100644
index 000000000000..a00f3aeb1f81
--- /dev/null
+++ b/app-admin/consolehm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>bsd@gentoo.org</email>
+ <name>BSD Project</name>
+</maintainer>
+</pkgmetadata>