summaryrefslogtreecommitdiff
path: root/app-admin/consolehm/consolehm-1.31.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/consolehm/consolehm-1.31.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/consolehm/consolehm-1.31.ebuild')
-rw-r--r--app-admin/consolehm/consolehm-1.31.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/consolehm/consolehm-1.31.ebuild b/app-admin/consolehm/consolehm-1.31.ebuild
new file mode 100644
index 000000000000..a0dda68d8469
--- /dev/null
+++ b/app-admin/consolehm/consolehm-1.31.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Console based hardware monitor for FreeBSD"
+HOMEPAGE="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/fenner/"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/fenner/${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~x86-fbsd"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-gcc4.patch || die "patch failed"
+ export CHMS="${S}/consolehm"
+ # The only 'SMBus' smb.h i've found is in a different place:
+ cd "${S}/consolehm"
+ sed -i.orig -e 's:machine/smb.h:dev/smbus/smb.h:g' \
+ configure.in \
+ configure \
+ chm.h || die "sed failed."
+}
+
+src_compile() {
+ cd "${S}/consolehm"
+ econf || die "econf failed"
+ MAKE=make emake || die "emake failed"
+}
+
+src_install() {
+ dobin "${S}/consolehm/chm"
+ doman "${S}/consolehm/chm.8"
+ dodoc "${S}"/CHANGELOG
+ dodoc "${S}"/README
+ dodoc "${S}"/TODO
+}