summaryrefslogtreecommitdiff
path: root/app-admin/conkyforecast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/conkyforecast
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/conkyforecast')
-rw-r--r--app-admin/conkyforecast/Manifest3
-rw-r--r--app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild44
-rw-r--r--app-admin/conkyforecast/metadata.xml11
3 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/conkyforecast/Manifest b/app-admin/conkyforecast/Manifest
new file mode 100644
index 000000000000..579cefa2c44e
--- /dev/null
+++ b/app-admin/conkyforecast/Manifest
@@ -0,0 +1,3 @@
+DIST conkyforecast_2.24.tar.gz 11347231 BLAKE2B 76d77229044375e7852823b92ac60cfafd190731e823a6e0d639ece16ef0dc94b7e182b4c6735529fc1f3145baa52c25412436acfb67ea69398a873aee81b14d SHA512 dcff08915c00915f6be4cd25824e3d8de978ed15ffb6776f002d585d95856f5e0827632371dd4d37016e07d58542e2bc95a7a859ebdc8ab9d1200ac04d4364e0
+EBUILD conkyforecast-2.24-r1.ebuild 1143 BLAKE2B 618f34f3c0260394f72ba7fadcabb372e7cc4cd63594e4abda88e5ad8399f28ea2931d09f6bd992ebe2339f717d4c37b89de14dad30e2e120ce7ee8ad5fe5308 SHA512 b269faef892efa7ded0d49830e0232fb2eefc95c55e24a6e50935aa40b9e2c0ad198c061237d7200a252a6169cc2480df6b1d865423963374375dc264f4c5695
+MISC metadata.xml 328 BLAKE2B 88458a82a675c10e772d5cdb3d84b2aeb55a12a2e24228d5cf4a8534851daba5cd244dfc20409988b25b7b5ea0cdbc61619fcf3a618e8633a9d47fa35765bce0 SHA512 b82738da77f143327af6973f163191826c7883fb1d3991f2c369ebcc84e50c71b1ea714d124562236501788fde015c3c3b33c4300561cc549a275931dc9fe426
diff --git a/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild b/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild
new file mode 100644
index 000000000000..2a1f73e2ee42
--- /dev/null
+++ b/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# upstream broke setup.py to install into /usr/share...
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Conky weather forecast script with support for language files"
+HOMEPAGE="https://launchpad.net/~conky-companions"
+SRC_URI="https://launchpad.net/~conky-companions/+archive/ppa/+files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/conky"
+
+S=${WORKDIR}/src
+
+python_prepare_all() {
+ sed -i -e "s:pythoncmd=.*$:pythoncmd=${EPYTHON}:" conkyForecast* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_optimize "${ED%/}"/usr/share/${PN}
+}
+
+pkg_postinst() {
+ elog "You have to define a partner id and registration code for "
+ elog "the weather.com xoap. You need to copy the template from"
+ elog "/usr/share/conkyforecast/conkyForecast.config into you account"
+ elog "as ~/.conkyForecast.config and edit the respective fields."
+ elog
+ elog "More details can be found in the README file."
+}
diff --git a/app-admin/conkyforecast/metadata.xml b/app-admin/conkyforecast/metadata.xml
new file mode 100644
index 000000000000..d9f08c9f2411
--- /dev/null
+++ b/app-admin/conkyforecast/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">~conky-companions</remote-id>
+ </upstream>
+</pkgmetadata>