summaryrefslogtreecommitdiff
path: root/app-admin/clog/clog-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/clog/clog-1.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/clog/clog-1.1.0.ebuild')
-rw-r--r--app-admin/clog/clog-1.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/clog/clog-1.1.0.ebuild b/app-admin/clog/clog-1.1.0.ebuild
new file mode 100644
index 000000000000..656fa519199d
--- /dev/null
+++ b/app-admin/clog/clog-1.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGIT_REPO_URI="https://git.tasktools.org/scm/ut/${PN}.git"
+[[ ${PV} == *9999* ]] && \
+ inherit git-2
+
+inherit cmake-utils bash-completion-r1
+
+DESCRIPTION="A colorized log tail utility"
+HOMEPAGE="http://tasktools.org/projects/clog.html"
+[[ ${PV} == *9999* ]] || \
+ SRC_URI="http://taskwarrior.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+[[ ${PV} == *9999* ]] || \
+ KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+src_prepare() {
+ # Use the correct directory locations
+ sed -i -e "s:/usr/local/share/doc/clog/rc:${EPREFIX}/usr/share/clog/rc:" \
+ doc/man/clog.1.in || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DTASK_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}