summaryrefslogtreecommitdiff
path: root/app-admin/checksec/checksec-1.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/checksec/checksec-1.7.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/checksec/checksec-1.7.3.ebuild')
-rw-r--r--app-admin/checksec/checksec-1.7.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/checksec/checksec-1.7.3.ebuild b/app-admin/checksec/checksec-1.7.3.ebuild
new file mode 100644
index 000000000000..e88dfd5d8fa1
--- /dev/null
+++ b/app-admin/checksec/checksec-1.7.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+MY_PN=${PN}.sh
+DESCRIPTION="Tool to check properties of executables (e.g. ASLR/PIE, RELRO, PaX, Canaries)"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+SRC_URI="https://github.com/slimm609/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.2-path.patch
+}
+
+src_install() {
+ default
+ dobin ${PN}
+}