summaryrefslogtreecommitdiff
path: root/app-admin/certmgr/certmgr-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/certmgr/certmgr-1.6.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/certmgr/certmgr-1.6.0.ebuild')
-rw-r--r--app-admin/certmgr/certmgr-1.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/certmgr/certmgr-1.6.0.ebuild b/app-admin/certmgr/certmgr-1.6.0.ebuild
new file mode 100644
index 000000000000..6951be522070
--- /dev/null
+++ b/app-admin/certmgr/certmgr-1.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/cloudflare/${PN}"
+inherit golang-build golang-vcs-snapshot
+
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Automated certificate management using a CFSSL CA"
+HOMEPAGE="https://github.com/cloudflare/certmgr"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src || die
+ GOPATH="${S}" go install -v ${EGO_PN}/cmd/... || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ pushd src/${EGO_PN} || die
+ dodoc README.md
+ popd || die
+}