summaryrefslogtreecommitdiff
path: root/app-admin/cdist/cdist-4.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/cdist/cdist-4.6.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/cdist/cdist-4.6.1.ebuild')
-rw-r--r--app-admin/cdist/cdist-4.6.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/cdist/cdist-4.6.1.ebuild b/app-admin/cdist/cdist-4.6.1.ebuild
new file mode 100644
index 000000000000..59661b8e4980
--- /dev/null
+++ b/app-admin/cdist/cdist-4.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="http://www.nico.schottelius.org/software/cdist/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/dist/html/*.html docs/dist/html/man{1,7}/*.html )
+ distutils-r1_python_install_all
+
+ doman docs/dist/man/man1/*.1 docs/dist/man/man7/*.7
+}