summaryrefslogtreecommitdiff
path: root/app-admin/ccze/ccze-0.2.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/ccze/ccze-0.2.1-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/ccze/ccze-0.2.1-r3.ebuild')
-rw-r--r--app-admin/ccze/ccze-0.2.1-r3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/ccze/ccze-0.2.1-r3.ebuild b/app-admin/ccze/ccze-0.2.1-r3.ebuild
new file mode 100644
index 000000000000..94fa5efed7b1
--- /dev/null
+++ b/app-admin/ccze/ccze-0.2.1-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit fixheadtails autotools eutils toolchain-funcs
+
+DESCRIPTION="A flexible and fast logfile colorizer"
+HOMEPAGE="https://dev.gentoo.org/~joker/ccze/ccze.txt"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/libpcre
+ sys-libs/ncurses:0="
+
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog ChangeLog-0.1 NEWS THANKS README FAQ )
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/ccze-fbsd.patch
+ epatch "${FILESDIR}"/ccze-segfault.patch
+ epatch "${FILESDIR}"/ccze-ldflags.patch
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+
+ # GCC 4.x fixes
+ sed -e 's/-Wswitch -Wmulticharacter/-Wswitch/' \
+ -i src/Makefile.in || die
+ sed -e '/AC_CHECK_TYPE(error_t, int)/d' \
+ -i configure.ac || die
+
+ eautoreconf
+
+ ht_fix_file Rules.mk.in
+
+ tc-export CC
+}