summaryrefslogtreecommitdiff
path: root/app-admin/cancd/cancd-0.1.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/cancd/cancd-0.1.0-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/cancd/cancd-0.1.0-r3.ebuild')
-rw-r--r--app-admin/cancd/cancd-0.1.0-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/cancd/cancd-0.1.0-r3.ebuild b/app-admin/cancd/cancd-0.1.0-r3.ebuild
new file mode 100644
index 000000000000..6ad37a6163ff
--- /dev/null
+++ b/app-admin/cancd/cancd-0.1.0-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="the CA NetConsole Daemon receives output from the Linux netconsole driver"
+HOMEPAGE="http://oss.oracle.com/projects/cancd/"
+SRC_URI="http://oss.oracle.com/projects/cancd/dist/files/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch #246734
+ epatch "${FILESDIR}"/${P}-c-cleanup.patch
+ # slight makefile cleanup
+ sed -i \
+ -e '/^CFLAGS/s,-g,,' \
+ -e '/^CFLAGS/s,-O2,-Wall -W -Wextra -Wundef -Wendif-labels -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Wsign-compare -Waggregate-return -Wstrict-prototypes -Wredundant-decls -Wunreachable-code -Wlong-long,' \
+ -e '/rm cancd cancd.o/s,rm,rm -f,' \
+ Makefile || die
+}
+
+src_install() {
+ dosbin cancd
+ newinitd "${FILESDIR}"/cancd-init.d cancd
+ newconfd "${FILESDIR}"/cancd-conf.d cancd
+ newinitd "${FILESDIR}"/netconsole-init.d netconsole
+ newconfd "${FILESDIR}"/netconsole-conf.d netconsole
+ keepdir /var/crash
+ fowners adm:nobody /var/crash
+ fperms 700 /var/crash
+}