summaryrefslogtreecommitdiff
path: root/app-admin/aws-rds-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/aws-rds-tools
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/aws-rds-tools')
-rw-r--r--app-admin/aws-rds-tools/Manifest5
-rw-r--r--app-admin/aws-rds-tools/aws-rds-tools-1.6.001.ebuild60
-rw-r--r--app-admin/aws-rds-tools/metadata.xml13
3 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/aws-rds-tools/Manifest b/app-admin/aws-rds-tools/Manifest
new file mode 100644
index 000000000000..873fc2cd34b6
--- /dev/null
+++ b/app-admin/aws-rds-tools/Manifest
@@ -0,0 +1,5 @@
+DIST RDSCli-1.6.001.zip 6291974 SHA256 2261aa6b89b7e22eefde751eeb7060f864efd64b494fdf43e5b8e9d2a1391087 SHA512 29eb31064cc9b067bdc625e9777dd1cc77bdbd01a167c91c396d52f89fd9617496e2383fe343a17abb0d8029e47eb87f8ae7e60c0dd5a89cee485dbe45a05963 WHIRLPOOL 8e73ff6cfa3ce5f32ad79f73e5e295f725f6adc75997bcd3a76b52a76de631a7eb2e3bd504ad6190785b7bf713951340ef7adb0e417fb5027c4cf974dcab43bd
+EBUILD aws-rds-tools-1.6.001.ebuild 1567 SHA256 fe28e96fc6a465d16557608c7af19f2b9277841443e71c40d5d764720a5cd0a9 SHA512 f42e7bdb03c95d5833a3181369bc97dfca1ef2458bcd0faa124b8a33609852b8d52985361620dbe9bc3c20aa3441e652416799014cbe78cdbfe35506372449ad WHIRLPOOL 8127fbd6919128711665746b281632084933a16e08c7371fa55aacb0f4e1b1a0401cda06ece21f841fe37caca1ed6cfb77396ad063a4ad70600220dad356ca6c
+MISC ChangeLog 2717 SHA256 00369eaec38625e543d918f191dbe0d0828add0a89d0078305b3a0d9b53538e1 SHA512 b2d638ff068094903c3cdca33676c7f4ec456a69f41db06ac569decdca8ccc43cc6cbe10ef227115817922a97da1915217b5800eda2316a6276ab10f4c81cf1c WHIRLPOOL 1c7de012012b71d0281d93513a6c4740711d781eb271ce83f5ce173eb38ae06e0b0de58d7150f0f618de055da95f1de942de9a92f38fe5c727157eb89e85156a
+MISC ChangeLog-2015 478 SHA256 2d59171439703869676a6cf0addf29cc52898beb85ca8d2542604e83da3537b8 SHA512 5b9aa7601a867ba92e0d829f9bdc5a703cb3f4298e980447fe3d83efdbd069639ab490706dfd8862247801ba3ade5989d7a058c0f0566f98545b1dda06a9bf64 WHIRLPOOL aad25875282b9208da9f3074a0ccd01c367f54cd9622c56abbb1abfc17267e6bd93f5187757a3c1d39451e71b52d0b52c3ad00af14819f6242e820a8ffbb4c41
+MISC metadata.xml 456 SHA256 7a4c38c99f18a4aaa5929fa65d9b943134b95f7a207c4bf41991b1c26cc9380e SHA512 aa4a57f4b0181ace33cad1698cdadd8cf41eb6f8fa8184ef415d09e0b0fbc81eaf579800c36040a9e01fb4fd2715e646a45d906d55e07617185ffe3f7b8538e8 WHIRLPOOL 832b7ad5979eacbdb07d1d635397656cd3310cb2f0b307c314735b0c6cdd11e577eb37175e52cc656f0b02c3af0cab52400ae002025d7230ab3f67cdba6cc976
diff --git a/app-admin/aws-rds-tools/aws-rds-tools-1.6.001.ebuild b/app-admin/aws-rds-tools/aws-rds-tools-1.6.001.ebuild
new file mode 100644
index 000000000000..4d0cfb2e1d01
--- /dev/null
+++ b/app-admin/aws-rds-tools/aws-rds-tools-1.6.001.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+DESCRIPTION="The Command Line Toolkit for the Amazon Relational Database Service"
+HOMEPAGE="http://aws.amazon.com/developertools/2928"
+SRC_URI="mirror://sabayon/${CATEGORY}/RDSCli-${PV}.zip"
+
+S="${WORKDIR}/RDSCli-${PV}"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd "$S"
+ find . -name '*.cmd' -delete || die
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+AWS_RDS_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc "THIRDPARTYLICENSE.TXT"
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full path to your AWS credentials file."
+ elog
+ elog " export AWS_CREDENTIAL_FILE=/path/and_filename_of_credential_file"
+ elog
+ elog "It should contains two lines: the first line lists the AWS Account's"
+ elog "AWS Access Key ID, and the second line lists the AWS Account's"
+ elog "Secret Access Key. For example:"
+ elog
+ elog " AWSAccessKeyId=AKIAIOSFODNN7EXAMPLE"
+ elog " AWSSecretKey=wJalrXUtnFEMI/K7MDENG/bPxRfiCYzEXAMPLEKEY"
+}
diff --git a/app-admin/aws-rds-tools/metadata.xml b/app-admin/aws-rds-tools/metadata.xml
new file mode 100644
index 000000000000..efd934a2bf23
--- /dev/null
+++ b/app-admin/aws-rds-tools/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sergey.zhuga@gmail.com</email>
+ <name>Sergey Zhuga</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>