summaryrefslogtreecommitdiff
path: root/app-admin/aws-elb-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/aws-elb-tools
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/aws-elb-tools')
-rw-r--r--app-admin/aws-elb-tools/Manifest3
-rw-r--r--app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild60
-rw-r--r--app-admin/aws-elb-tools/metadata.xml5
3 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/aws-elb-tools/Manifest b/app-admin/aws-elb-tools/Manifest
new file mode 100644
index 000000000000..3ce8b7d4817e
--- /dev/null
+++ b/app-admin/aws-elb-tools/Manifest
@@ -0,0 +1,3 @@
+DIST ElasticLoadBalancing-1.0.15.1.zip 6717939 BLAKE2B deef8cfb32a9c0d3627af26f32430efbe27a7712acd7c5dd9b7e8947b7c16ac866cec64100dd1bc315c4a2729451d181da8d16f133ea81fc927452cce6cc4f9b SHA512 813f00d632b483a5ec98632d830be4b02fc1bc71aa7bd845faa477f7d05bda7c801e5d83992c111dfc136bf5e1204bf96b00a1c24e5b19438decb356d0841725
+EBUILD aws-elb-tools-1.0.15.1-r1.ebuild 1562 BLAKE2B 54ac1fd7d026dd4f58dc2d1a294efa97ca4f6c94c869a968cee44e104e31356be2309e931d1c764fa5d8e1b5a1ee2c10df49880fb8d223d6927ccc34e9432b62 SHA512 a443939e59330c71b6b360c0420d18649ea21c26eefb4f8da961295faed18242578354bc954c8d64359168308b8a3d1a2bb57116c515e1ea734e87ac17c01672
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild
new file mode 100644
index 000000000000..7b6784456062
--- /dev/null
+++ b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Serves as the client interface to the Elastic Load Balancing web service"
+HOMEPAGE="http://aws.amazon.com/developertools/Amazon-EC2/2536"
+SRC_URI="mirror://sabayon/${CATEGORY}/ElasticLoadBalancing-${PV}.zip"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+
+S="${WORKDIR}/ElasticLoadBalancing-${PV}"
+
+src_prepare() {
+ default
+ find . -name '*.cmd' -delete || die
+}
+
+src_install() {
+ insinto /opt/${PN}/lib
+ doins -r lib/.
+
+ exeinto /opt/${PN}/bin
+ doexe bin/*
+
+ cat > "${T}"/99${PN} <<- EOF || die
+ AWS_ELB_HOME=/opt/${PN}
+ PATH=/opt/${PN}/bin
+ ROOTPATH=/opt/${PN}/bin
+ EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc THIRDPARTYLICENSE.TXT
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+
+ elog
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full path to your AWS credentials file."
+ elog
+ elog " export AWS_CREDENTIAL_FILE=/path/and_filename_of_credential_file"
+ elog
+ elog "It should contains two lines: the first line lists the AWS Account's"
+ elog "AWS Access Key ID, and the second line lists the AWS Account's"
+ elog "Secret Access Key. For example:"
+ elog
+ elog " AWSAccessKeyId=AKIAIOSFODNN7EXAMPLE"
+ elog " AWSSecretKey=wJalrXUtnFEMI/K7MDENG/bPxRfiCYzEXAMPLEKEY"
+}
diff --git a/app-admin/aws-elb-tools/metadata.xml b/app-admin/aws-elb-tools/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-admin/aws-elb-tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>