summaryrefslogtreecommitdiff
path: root/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild')
-rw-r--r--app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild b/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
new file mode 100644
index 000000000000..38450b0e2f07
--- /dev/null
+++ b/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+DESCRIPTION="The API tools serve as the client interface to the Auto Scaling web service"
+HOMEPAGE="http://aws.amazon.com/developertools/2535"
+# SRC_URI="http://ec2-downloads.s3.amazonaws.com/AutoScaling-2011-01-01.zip"
+SRC_URI="mirror://sabayon/app-admin/AutoScaling-1.0.49.1.zip"
+
+S="${WORKDIR}/AutoScaling-${PV}"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find . -name '*.cmd' -delete || die
+ rm bin/as-cmd-2009-05-15
+ rm bin/service-2009-05-15
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+AWS_AUTO_SCALING_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc "THIRDPARTYLICENSE.TXT"
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full path to your AWS credentials file."
+ elog
+ elog " export AWS_CREDENTIAL_FILE=/path/and_filename_of_credential_file"
+ elog
+ elog "It should contains two lines: the first line lists the AWS Account's"
+ elog "AWS Access Key ID, and the second line lists the AWS Account's"
+ elog "Secret Access Key. For example:"
+ elog
+ elog " AWSAccessKeyId=AKIAIOSFODNN7EXAMPLE"
+ elog " AWSSecretKey=wJalrXUtnFEMI/K7MDENG/bPxRfiCYzEXAMPLEKEY"
+}