summaryrefslogtreecommitdiff
path: root/app-admin/authbind/authbind-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/authbind/authbind-2.1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/authbind/authbind-2.1.1.ebuild')
-rw-r--r--app-admin/authbind/authbind-2.1.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/authbind/authbind-2.1.1.ebuild b/app-admin/authbind/authbind-2.1.1.ebuild
new file mode 100644
index 000000000000..c7a9890aa7ce
--- /dev/null
+++ b/app-admin/authbind/authbind-2.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib flag-o-matic
+
+DESCRIPTION="Bind sockets to privileged ports without root"
+HOMEPAGE="http://www.chiark.greenend.org.uk/ucgi/~ian/git/authbind.git/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-respect-flags.patch"
+}
+
+src_configure() {
+ sed -i \
+ -e "s|^prefix=.*|prefix=/usr|" \
+ -e "s|^lib_dir=.*|lib_dir=\$(prefix)/$(get_libdir)|" \
+ -e "s|^libexec_dir=.*|libexec_dir=\$(prefix)/libexec/authbind|" \
+ -e "s|^SHARED_LDFLAGS=.*|SHARED_LDFLAGS=$(raw-ldflags)|" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e 's|/usr/lib|/usr/libexec|' \
+ authbind-helper.8 || die "sed failed"
+}
+
+src_install() {
+ dobin authbind
+ doman authbind.1 authbind-helper.8
+
+ ln -s libauthbind.so.* libauthbind.so.$(awk -F= '/MAJOR=/ { print $2 }' < Makefile)
+ dolib.so libauthbind.so*
+
+ exeinto /usr/libexec/authbind
+ exeopts -m4755
+ doexe helper
+
+ keepdir /etc/authbind/by{addr,port,uid}
+
+ dodoc debian/changelog
+}