summaryrefslogtreecommitdiff
path: root/app-admin/apachetop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/apachetop/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/apachetop/files')
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-ac_config_header.patch12
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-configure.patch101
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch13
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-maxpathlen.patch39
4 files changed, 165 insertions, 0 deletions
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-ac_config_header.patch b/app-admin/apachetop/files/apachetop-0.12.6-ac_config_header.patch
new file mode 100644
index 000000000000..aabdb13d75f3
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-ac_config_header.patch
@@ -0,0 +1,12 @@
+diff -uNr apachetop-0.12.6.orig/configure.ac apachetop-0.12.6/configure.ac
+--- apachetop-0.12.6.orig/configure.ac 2013-07-09 14:06:14.000000000 -0400
++++ apachetop-0.12.6/configure.ac 2013-07-09 14:07:36.000000000 -0400
+@@ -6,7 +6,7 @@
+ AC_CONFIG_AUX_DIR(config)
+ #AC_CONFIG_MACRO_DIR(m4) # 2.58
+
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADER(config.h)
+ AM_INIT_AUTOMAKE(apachetop, 0.12.6) # 2.53 only?
+
+ # Add non-standard directories to the include path
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-configure.patch b/app-admin/apachetop/files/apachetop-0.12.6-configure.patch
new file mode 100644
index 000000000000..38a1fc7f6a1a
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-configure.patch
@@ -0,0 +1,101 @@
+Index: apachetop-0.12.6/configure.ac
+===================================================================
+--- apachetop-0.12.6.orig/configure.ac
++++ apachetop-0.12.6/configure.ac
+@@ -52,48 +52,60 @@ AC_FUNC_VPRINTF
+ AC_CHECK_FUNCS([inet_aton memset strchr strdup kqueue strerror strstr])
+
+ # pcre {{{
+-AC_ARG_WITH(pcre,
+- [ --with-pcre=<path> prefix of pcre installation (eg /usr/local)],
+- [
+- CPPFLAGS="$CPPFLAGS -I $withval/include"
+- LDFLAGS="$LDFLAGS -L $withval/lib"
+- ]
+-)
+-
+-AC_CHECK_HEADERS(pcre.h,
+- AC_SEARCH_LIBS([pcre_compile], [pcre]) ,
+- AC_MSG_WARN([*** pcre.h not found -- consider using --with-pcre])
+-)
++AC_ARG_WITH([pcre],
++ [ --with-pcre=<path> prefix of pcre installation (eg /usr/local)],
++ [case "${withval}" in
++ yes) with_pcre="/usr";;
++ no) with_pcre="no";;
++ *) with_pcre="/usr";;
++ esac],
++ [with_pcre="/usr"])
++
++if test x$with_pcre != xno; then
++ CPPFLAGS="$CPPFLAGS -I $withval/include"
++ LDFLAGS="$LDFLAGS -L $withval/lib"
++ AC_CHECK_HEADERS(pcre.h,
++ AC_SEARCH_LIBS([pcre_compile], [pcre]),
++ AC_MSG_WARN([*** pcre.h not found -- consider using --with-pcre]))
++fi
+ # }}}
+
+ # fam {{{
+-AC_ARG_WITH(fam,
+- [ --with-fam=<path> prefix of fam installation (eg /usr/local)],
+- [
+- CPPFLAGS="$CPPFLAGS -I $withval/include"
+- LDFLAGS="$LDFLAGS -L $withval/lib"
+- ]
+-)
+-
+-AC_CHECK_HEADERS(fam.h,
+- AC_SEARCH_LIBS([FAMOpen], [fam]) ,
+- AC_MSG_WARN([*** fam.h not found -- consider using --with-fam])
+-)
++AC_ARG_WITH([fam],
++ [ --with-fam=<path> prefix of fam installation (eg /usr/local)],
++ [case "${withval}" in
++ yes) with_fam="/usr";;
++ no) with_fam="no";;
++ *) with_fam="/usr";;
++ esac],
++ [with_fam="/usr"])
++
++if test x$with_fam != xno; then
++ CPPFLAGS="$CPPFLAGS -I $with_fam/include"
++ LDFLAGS="$LDFLAGS -L $with_fam/lib"
++ AC_CHECK_HEADERS(fam.h,
++ AC_SEARCH_LIBS([FAMOpen], [fam]),
++ AC_MSG_WARN([*** fam.h not found -- consider using --with-fam]))
++fi
+ # }}}
+
+ # adns {{{
+-AC_ARG_WITH(adns,
+- [ --with-adns=<path> prefix of adns installation (eg /usr/local)],
+- [
+- CPPFLAGS="$CPPFLAGS -I $withval/include"
+- LDFLAGS="$LDFLAGS -L $withval/lib"
+- ]
+-)
+-
+-AC_CHECK_HEADERS(adns.h,
+- AC_SEARCH_LIBS([adns_submit], [adns]) ,
+- AC_MSG_WARN([*** adns.h not found -- consider using --with-adns])
+-)
++AC_ARG_WITH([adns],
++ [ --with-adns=<path> prefix of adns installation (eg /usr/local)],
++ [case "${withval}" in
++ yes) with_adns="/usr";;
++ no) with_adns="no";;
++ *) with_adns="/usr";;
++ esac],
++ [with_adns="/usr"])
++
++if test x$with_adns != xno; then
++ CPPFLAGS="$CPPFLAGS -I $with_adns/include"
++ LDFLAGS="$LDFLAGS -L $with_adns/lib"
++ AC_CHECK_HEADERS(adns.h,
++ AC_SEARCH_LIBS([adns_submit], [adns]),
++ AC_MSG_WARN([*** adns.h not found -- consider using --with-adns]))
++fi
+ # }}}
+
+ # --with-logfile {{{
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch b/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch
new file mode 100644
index 000000000000..566c9226a3f7
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch
@@ -0,0 +1,13 @@
+--- src/resolver.h
++++ src/resolver.h
+@@ -10,8 +10,8 @@
+ class Resolver
+ {
+ public:
+- Resolver::Resolver(void);
+- Resolver::~Resolver(void);
++ Resolver(void);
++ ~Resolver(void);
+ int add_request(char *request, enum resolver_action act);
+
+
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-maxpathlen.patch b/app-admin/apachetop/files/apachetop-0.12.6-maxpathlen.patch
new file mode 100644
index 000000000000..b648b07cbfc5
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-maxpathlen.patch
@@ -0,0 +1,39 @@
+Patch by Robert Scheck <robert@fedoraproject.org> for apachetop <= 0.12.6, which
+adds some includes in order to have a real change to get MAXPATHLEN defined with
+a valid value. Once MAXPATHLEN really gets filled with 128, it will just cause a
+buffer overflow.
+
+See Red Hat Bugzilla #446199 (https://bugzilla.redhat.com/show_bug.cgi?id=446199)
+for more information. This patch should solve the mentioned bug report and should
+be sane enough to get included by upstream of apachetop for the next release. It
+is important to run autoheader before ./configure to get these changes activated.
+
+--- apachetop-0.12.6/configure.ac 2005-10-27 18:39:25.000000000 +0200
++++ apachetop-0.12.6/configure.ac.maxpathlen 2008-06-21 16:00:38.000000000 +0200
+@@ -34,7 +34,8 @@
+ # Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h \
+- string.h strings.h sys/socket.h time.h sys/time.h])
++ string.h strings.h sys/socket.h time.h sys/time.h \
++ limits.h sys/param.h])
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ #AC_HEADER_STDBOOL # not in 2.53?
+--- apachetop-0.12.6/src/apachetop.h 2005-10-15 18:10:01.000000000 +0200
++++ apachetop-0.12.6/src/apachetop.h.maxpatlen 2008-06-21 16:02:00.000000000 +0200
+@@ -89,8 +89,12 @@
+ #define getMIN(a,b) (a < b ? a : b)
+ #define getMAX(a,b) (a > b ? a : b)
+
+-#ifndef MAXPATHLEN
+-# define MAXPATHLEN 128
++#ifdef HAVE_SYS_PARAM_H
++# include <sys/param.h>
++#endif
++
++#if HAVE_LIMITS_H
++# include <limits.h>
+ #endif
+
+ /* upon startup, each input file is put into an element of this array,