summaryrefslogtreecommitdiff
path: root/app-admin/apachetop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/apachetop/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/apachetop/files')
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-ac_config_header.patch12
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-configure.patch101
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch13
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-maxpathlen.patch39
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-ncurses.patch166
5 files changed, 331 insertions, 0 deletions
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-ac_config_header.patch b/app-admin/apachetop/files/apachetop-0.12.6-ac_config_header.patch
new file mode 100644
index 000000000000..aabdb13d75f3
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-ac_config_header.patch
@@ -0,0 +1,12 @@
+diff -uNr apachetop-0.12.6.orig/configure.ac apachetop-0.12.6/configure.ac
+--- apachetop-0.12.6.orig/configure.ac 2013-07-09 14:06:14.000000000 -0400
++++ apachetop-0.12.6/configure.ac 2013-07-09 14:07:36.000000000 -0400
+@@ -6,7 +6,7 @@
+ AC_CONFIG_AUX_DIR(config)
+ #AC_CONFIG_MACRO_DIR(m4) # 2.58
+
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADER(config.h)
+ AM_INIT_AUTOMAKE(apachetop, 0.12.6) # 2.53 only?
+
+ # Add non-standard directories to the include path
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-configure.patch b/app-admin/apachetop/files/apachetop-0.12.6-configure.patch
new file mode 100644
index 000000000000..38a1fc7f6a1a
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-configure.patch
@@ -0,0 +1,101 @@
+Index: apachetop-0.12.6/configure.ac
+===================================================================
+--- apachetop-0.12.6.orig/configure.ac
++++ apachetop-0.12.6/configure.ac
+@@ -52,48 +52,60 @@ AC_FUNC_VPRINTF
+ AC_CHECK_FUNCS([inet_aton memset strchr strdup kqueue strerror strstr])
+
+ # pcre {{{
+-AC_ARG_WITH(pcre,
+- [ --with-pcre=<path> prefix of pcre installation (eg /usr/local)],
+- [
+- CPPFLAGS="$CPPFLAGS -I $withval/include"
+- LDFLAGS="$LDFLAGS -L $withval/lib"
+- ]
+-)
+-
+-AC_CHECK_HEADERS(pcre.h,
+- AC_SEARCH_LIBS([pcre_compile], [pcre]) ,
+- AC_MSG_WARN([*** pcre.h not found -- consider using --with-pcre])
+-)
++AC_ARG_WITH([pcre],
++ [ --with-pcre=<path> prefix of pcre installation (eg /usr/local)],
++ [case "${withval}" in
++ yes) with_pcre="/usr";;
++ no) with_pcre="no";;
++ *) with_pcre="/usr";;
++ esac],
++ [with_pcre="/usr"])
++
++if test x$with_pcre != xno; then
++ CPPFLAGS="$CPPFLAGS -I $withval/include"
++ LDFLAGS="$LDFLAGS -L $withval/lib"
++ AC_CHECK_HEADERS(pcre.h,
++ AC_SEARCH_LIBS([pcre_compile], [pcre]),
++ AC_MSG_WARN([*** pcre.h not found -- consider using --with-pcre]))
++fi
+ # }}}
+
+ # fam {{{
+-AC_ARG_WITH(fam,
+- [ --with-fam=<path> prefix of fam installation (eg /usr/local)],
+- [
+- CPPFLAGS="$CPPFLAGS -I $withval/include"
+- LDFLAGS="$LDFLAGS -L $withval/lib"
+- ]
+-)
+-
+-AC_CHECK_HEADERS(fam.h,
+- AC_SEARCH_LIBS([FAMOpen], [fam]) ,
+- AC_MSG_WARN([*** fam.h not found -- consider using --with-fam])
+-)
++AC_ARG_WITH([fam],
++ [ --with-fam=<path> prefix of fam installation (eg /usr/local)],
++ [case "${withval}" in
++ yes) with_fam="/usr";;
++ no) with_fam="no";;
++ *) with_fam="/usr";;
++ esac],
++ [with_fam="/usr"])
++
++if test x$with_fam != xno; then
++ CPPFLAGS="$CPPFLAGS -I $with_fam/include"
++ LDFLAGS="$LDFLAGS -L $with_fam/lib"
++ AC_CHECK_HEADERS(fam.h,
++ AC_SEARCH_LIBS([FAMOpen], [fam]),
++ AC_MSG_WARN([*** fam.h not found -- consider using --with-fam]))
++fi
+ # }}}
+
+ # adns {{{
+-AC_ARG_WITH(adns,
+- [ --with-adns=<path> prefix of adns installation (eg /usr/local)],
+- [
+- CPPFLAGS="$CPPFLAGS -I $withval/include"
+- LDFLAGS="$LDFLAGS -L $withval/lib"
+- ]
+-)
+-
+-AC_CHECK_HEADERS(adns.h,
+- AC_SEARCH_LIBS([adns_submit], [adns]) ,
+- AC_MSG_WARN([*** adns.h not found -- consider using --with-adns])
+-)
++AC_ARG_WITH([adns],
++ [ --with-adns=<path> prefix of adns installation (eg /usr/local)],
++ [case "${withval}" in
++ yes) with_adns="/usr";;
++ no) with_adns="no";;
++ *) with_adns="/usr";;
++ esac],
++ [with_adns="/usr"])
++
++if test x$with_adns != xno; then
++ CPPFLAGS="$CPPFLAGS -I $with_adns/include"
++ LDFLAGS="$LDFLAGS -L $with_adns/lib"
++ AC_CHECK_HEADERS(adns.h,
++ AC_SEARCH_LIBS([adns_submit], [adns]),
++ AC_MSG_WARN([*** adns.h not found -- consider using --with-adns]))
++fi
+ # }}}
+
+ # --with-logfile {{{
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch b/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch
new file mode 100644
index 000000000000..6bfb49d9f9d8
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch
@@ -0,0 +1,13 @@
+--- a/src/resolver.h
++++ b/src/resolver.h
+@@ -10,8 +10,8 @@
+ class Resolver
+ {
+ public:
+- Resolver::Resolver(void);
+- Resolver::~Resolver(void);
++ Resolver(void);
++ ~Resolver(void);
+ int add_request(char *request, enum resolver_action act);
+
+
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-maxpathlen.patch b/app-admin/apachetop/files/apachetop-0.12.6-maxpathlen.patch
new file mode 100644
index 000000000000..b648b07cbfc5
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-maxpathlen.patch
@@ -0,0 +1,39 @@
+Patch by Robert Scheck <robert@fedoraproject.org> for apachetop <= 0.12.6, which
+adds some includes in order to have a real change to get MAXPATHLEN defined with
+a valid value. Once MAXPATHLEN really gets filled with 128, it will just cause a
+buffer overflow.
+
+See Red Hat Bugzilla #446199 (https://bugzilla.redhat.com/show_bug.cgi?id=446199)
+for more information. This patch should solve the mentioned bug report and should
+be sane enough to get included by upstream of apachetop for the next release. It
+is important to run autoheader before ./configure to get these changes activated.
+
+--- apachetop-0.12.6/configure.ac 2005-10-27 18:39:25.000000000 +0200
++++ apachetop-0.12.6/configure.ac.maxpathlen 2008-06-21 16:00:38.000000000 +0200
+@@ -34,7 +34,8 @@
+ # Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h \
+- string.h strings.h sys/socket.h time.h sys/time.h])
++ string.h strings.h sys/socket.h time.h sys/time.h \
++ limits.h sys/param.h])
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ #AC_HEADER_STDBOOL # not in 2.53?
+--- apachetop-0.12.6/src/apachetop.h 2005-10-15 18:10:01.000000000 +0200
++++ apachetop-0.12.6/src/apachetop.h.maxpatlen 2008-06-21 16:02:00.000000000 +0200
+@@ -89,8 +89,12 @@
+ #define getMIN(a,b) (a < b ? a : b)
+ #define getMAX(a,b) (a > b ? a : b)
+
+-#ifndef MAXPATHLEN
+-# define MAXPATHLEN 128
++#ifdef HAVE_SYS_PARAM_H
++# include <sys/param.h>
++#endif
++
++#if HAVE_LIMITS_H
++# include <limits.h>
+ #endif
+
+ /* upon startup, each input file is put into an element of this array,
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-ncurses.patch b/app-admin/apachetop/files/apachetop-0.12.6-ncurses.patch
new file mode 100644
index 000000000000..f12c989c3407
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-ncurses.patch
@@ -0,0 +1,166 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,7 +4,7 @@
+ AC_CONFIG_SRCDIR(src/apachetop.cc)
+
+ AC_CONFIG_AUX_DIR(config)
+-#AC_CONFIG_MACRO_DIR(m4) # 2.58
++AC_CONFIG_MACRO_DIR(m4)
+
+ AC_CONFIG_HEADER(config.h)
+ AM_INIT_AUTOMAKE(apachetop, 0.12.6) # 2.53 only?
+@@ -29,7 +29,6 @@
+ #AC_PROG_CC
+ #AC_PROG_CPP
+ AC_PROG_CXX
+-AC_LANG_CPLUSPLUS
+
+ # Checks for header files.
+ AC_HEADER_STDC
+@@ -120,24 +119,9 @@
+
+ AC_SEARCH_LIBS([socket], [socket])
+ AC_SEARCH_LIBS([inet_addr], [nsl])
+-AC_SEARCH_LIBS([attron], [ncurses])
+-AC_SEARCH_LIBS([tgetstr], [termcap])
+-AC_SEARCH_LIBS([mvprintw], [curses ncurses] ,
+- [] ,
+- [
+- AC_MSG_ERROR([No useful curses library found!])
+- ]
+-)
+
+-AC_SEARCH_LIBS([readline], [readline],
+- [
+- AC_DEFINE(HAVE_READLINE,1,[Define if you have readline library])
+- AC_SUBST(HAVE_READLINE)
+- ] ,
+- [
+- AC_MSG_ERROR(readline library not found)
+- ]
+-)
++PKG_CHECK_MODULES([NCURSES], [ncurses])
++AX_LIB_READLINE
+
+
+ # everything is in CPPFLAGS up to this point, now we move to CXXFLAGS
+--- a/m4/ax_lib_readline.m4
++++ b/m4/ax_lib_readline.m4
+@@ -0,0 +1,107 @@
++# ===========================================================================
++# https://www.gnu.org/software/autoconf-archive/ax_lib_readline.html
++# ===========================================================================
++#
++# SYNOPSIS
++#
++# AX_LIB_READLINE
++#
++# DESCRIPTION
++#
++# Searches for a readline compatible library. If found, defines
++# `HAVE_LIBREADLINE'. If the found library has the `add_history' function,
++# sets also `HAVE_READLINE_HISTORY'. Also checks for the locations of the
++# necessary include files and sets `HAVE_READLINE_H' or
++# `HAVE_READLINE_READLINE_H' and `HAVE_READLINE_HISTORY_H' or
++# 'HAVE_HISTORY_H' if the corresponding include files exists.
++#
++# The libraries that may be readline compatible are `libedit',
++# `libeditline' and `libreadline'. Sometimes we need to link a termcap
++# library for readline to work, this macro tests these cases too by trying
++# to link with `libtermcap', `libcurses' or `libncurses' before giving up.
++#
++# Here is an example of how to use the information provided by this macro
++# to perform the necessary includes or declarations in a C file:
++#
++# #ifdef HAVE_LIBREADLINE
++# # if defined(HAVE_READLINE_READLINE_H)
++# # include <readline/readline.h>
++# # elif defined(HAVE_READLINE_H)
++# # include <readline.h>
++# # else /* !defined(HAVE_READLINE_H) */
++# extern char *readline ();
++# # endif /* !defined(HAVE_READLINE_H) */
++# char *cmdline = NULL;
++# #else /* !defined(HAVE_READLINE_READLINE_H) */
++# /* no readline */
++# #endif /* HAVE_LIBREADLINE */
++#
++# #ifdef HAVE_READLINE_HISTORY
++# # if defined(HAVE_READLINE_HISTORY_H)
++# # include <readline/history.h>
++# # elif defined(HAVE_HISTORY_H)
++# # include <history.h>
++# # else /* !defined(HAVE_HISTORY_H) */
++# extern void add_history ();
++# extern int write_history ();
++# extern int read_history ();
++# # endif /* defined(HAVE_READLINE_HISTORY_H) */
++# /* no history */
++# #endif /* HAVE_READLINE_HISTORY */
++#
++# LICENSE
++#
++# Copyright (c) 2008 Ville Laurikari <vl@iki.fi>
++#
++# Copying and distribution of this file, with or without modification, are
++# permitted in any medium without royalty provided the copyright notice
++# and this notice are preserved. This file is offered as-is, without any
++# warranty.
++
++#serial 7
++
++AU_ALIAS([VL_LIB_READLINE], [AX_LIB_READLINE])
++AC_DEFUN([AX_LIB_READLINE], [
++ AC_CACHE_CHECK([for a readline compatible library],
++ ax_cv_lib_readline, [
++ ORIG_LIBS="$LIBS"
++ for readline_lib in readline edit editline; do
++ for termcap_lib in "" termcap curses ncurses; do
++ if test -z "$termcap_lib"; then
++ TRY_LIB="-l$readline_lib"
++ else
++ TRY_LIB="-l$readline_lib -l$termcap_lib"
++ fi
++ LIBS="$ORIG_LIBS $TRY_LIB"
++ AC_TRY_LINK_FUNC(readline, ax_cv_lib_readline="$TRY_LIB")
++ if test -n "$ax_cv_lib_readline"; then
++ break
++ fi
++ done
++ if test -n "$ax_cv_lib_readline"; then
++ break
++ fi
++ done
++ if test -z "$ax_cv_lib_readline"; then
++ ax_cv_lib_readline="no"
++ fi
++ LIBS="$ORIG_LIBS"
++ ])
++
++ if test "$ax_cv_lib_readline" != "no"; then
++ LIBS="$LIBS $ax_cv_lib_readline"
++ AC_DEFINE(HAVE_LIBREADLINE, 1,
++ [Define if you have a readline compatible library])
++ AC_CHECK_HEADERS(readline.h readline/readline.h)
++ AC_CACHE_CHECK([whether readline supports history],
++ ax_cv_lib_readline_history, [
++ ax_cv_lib_readline_history="no"
++ AC_TRY_LINK_FUNC(add_history, ax_cv_lib_readline_history="yes")
++ ])
++ if test "$ax_cv_lib_readline_history" = "yes"; then
++ AC_DEFINE(HAVE_READLINE_HISTORY, 1,
++ [Define if your readline library has \`add_history'])
++ AC_CHECK_HEADERS(history.h readline/history.h)
++ fi
++ fi
++])dnl
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -6,6 +6,7 @@
+ display.cc hits_circle.cc timed_circle.cc filters.cc \
+ resolver.cc
+
++apachetop_LDADD = $(NCURSES_LIBS)
+
+ noinst_HEADERS = apachetop.h log.h ohtbl.h map.h queue.h \
+ display.h hits_circle.h circle.h timed_circle.h filters.h \